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Notation Used in this Document 

• Key sequences that you may type are enclosed in a box.  For example,   

Enter  indicates that you are should press the “Enter” key. 

• Dialog buttons are enclosed in a box with a gray background.  For example, 

where this document says “Select  OK ”, you should click the OK button or 

navigate to the OK button and press the  Enter  key. 

• Menu sequences are indicated by one or more items with a gray background 

(and no box), and separated by an arrow character “➔”.  For example, to 

open a file you navigate with the mouse or the keyboard to the File ➔ Open 

dialog. 

• Sections that apply only to Time Series Mode are marked with the  icon, 
and those that apply only to Assembly Mode are marked with the  icon.  

These modes are explained later. 
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Overview 

TenGun is a high-performance, easy-to-use 

tool for working with Point Cloud data, and 
is available for Windows, Linux, and macOS. 
It is primarily targeted for use with SPH 

(Smoothed Particle Hydrodynamics), CFD 
(Computational Fluid Dynamics), and similar 

analysis applications. 
 
 

TenGun has the following usage scenarios: 
 

• Post-Processing, which we call “Time Series Mode”.  This mode is used 
to graphically inspect the output of an analysis application. 

• Pre-Processing, which we call “Assembly Mode”.  This mode is used to 

assemble the parts from a CAD application and to convert them to the 
input format of the analysis application. 

• Text Editing.  The editor can work with files either related to your analysis 
work as well as files some other, unrelated use.  

 
These usage scenarios are discussed in the following chapters. 
  

TenGun (点群, pronounced like "Ten 
Goon"), literally means "Point Cloud" in 
Japanese. 
 
This is not to be confused with the 

mythical Tengu (天狗) creature, which 
is what everyone insisted on hearing 
when I suggested this name. 
 

- The author - 
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Getting Started 

To start, follow these steps: 

 

• Install the program by opening TenGunSetup.msi. This is a 

straightforward Windows setup application. 

• Obtain and install a License (refer to License Installation). 

• Run TenGun, either from the Desktop shortcut, the Start Menu shortcut, 
or from the command line. 

• If you are using simple data files that do not contain a field information 

header, you must register the list of fields in your data. This can be done 
in the Edit ➔ Settings screen.  

License Installation 

TenGun is available with the following licensing options: 

 

• Free.  Includes the basic Time Series Mode viewer functionality and 

supports a limited number of particles. It may be used for non-
commercial use, and no support is provided. 

• Advanced Viewer.  Time Series Mode viewer, no particle limit, may be 
used for commercial use, and support is available. 

• Reporter.  Same as above, and allows creation of Reports and Charts. 

• Professional.  All features including Assembly Mode pre-processing 
features. 

 
The "Free" version does not require a license file. 

 
Advanced Viewers features and above require a valid software license to 
operate. To set up a license: 

 

• Start TenGun and go to the Help ➔ About window. 

• Click the “Request License for MAC Address xx-xx-xx-xx-xx-xx” link. This 
will send an email to us to request a license. 

• You will receive a reply with an attached file named "TenGun.lic"." You 
may manually copy this to "C:\ProgramData\TenGun", or you may do the 

following: 
 

o Drag & Drop TenGun.lic to any folder, for example your Desktop 

folder. 
o Start TenGun if it is not already running. 

o Drag the license file into the TenGun main window. 
o TenGun will install the license file for you. 
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NOTE: You cannot directly Drag & Drop an email attachment to install it. 

However, you may first move the attachment to the file system (e.g., to the 
Desktop), and then drag it into TenGun. 

Command Line Options 

The only command line option is currently “-lang”.  The default language is the 
same as the System language.  To override the default specify “-lang en” for 

English, or “-lang ja” for Japanese.  
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Input File Formats 

TenGun supports the following types of input files for Time Series and 

Assembly Modes. 
 

Type Extension Description Use Case 

Plain data .dat Simple data file with no information 
about the structure. 

Time Series 
Mode from 
analysis output. 

BMP .bmp Windows BitMaP image file.  

CSV .csv "Comma Separated Values". The first 
line of the file is expected to contain the 
names of the fields, and must minimally 
include fields X, Y, and Z. CSV files can 
be imported by many applications 
including spreadsheets.  

Time Series 
Mode from 
analysis output. 

DICOM .dcm Digital Imaging and Communications in 
Medicine (Xrays, CT-Scans, MRI 
scans). 

 

IGES .igs, .iges "Initial Graphics Exchange 
Specification".  A standardized format 
for exchanging CAD drawings. 

Assembly Mode 
from CAD 
exchange. 

JPEG .jpg, .jpeg Joint Photographic Experts Group 
image file. 

 

LS-DYNA 
 

LS-DYNA d3plot.  There are a huge 
number of variations for this format, so 

this is currently an Experimental 
Feature. 

 

OBJ .obj A geometry definition file format 
originally developed by Wavefront 
Technologies that contains geometry 
and texture information. 

Assembly Mode 
from CAD 
exchange. 

PLY .ply "Polygon File Format" or "Stanford 
Triangle Format". Simple format 
originally designed to store 3D-Scanner 
data.  Binary and ASCII formats. 

Assembly Mode 
from CAD 
exchange. 

PNG .png Portable Network Graphics image file.  

STEP .stp, .step A widely used CAD exchange format 
standardized under ISO 10303.  
TenGun supports the ISO 10303-203 
and ISO 10303-214 variants, which are 
used in mechanical and automotive 
design, respectively.  Some other 
variants may work. 

Assembly Mode 
CAD exchange. 

STL .stl A "Stereolithography" file. Contains 
simple 3D triangulated surfaces but not 
much other information.  Binary and 
ASCII formats. 

Assembly Mode 
from CAD 
exchange. 

VTK .vtk A legacy "Visual ToolKit" file. Binary 
and ASCII formats. 

Data exchange 
with other 
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graphics 
applications 
based on "VTK". 

VTP .vtp A "Visual ToolKit" XML-based file.  
Binary and ASCII formats. 

Data exchange 
with other 
graphics 
applications 
based on "VTK". 

 

Hints 

• If you are working with CAD data in TenGun, we strongly recommend that 

you use STEP format if possible.  Although STL files are common, it is not a 
good format for CAD models.  STL was designed to store 3D-Printer data, 

and these files do not contain design attributes that we need to perform 
advanced editing operations.  Furthermore, STL handling can be slow 
because even seemingly simple objects can be represented internally by 

many thousands of triangles. 

• LS-DYNA “d3plot” files is just one of the files created by an LS-DYNA 

analysis.  For TenGun to read LS-DYNA data you must provide all of the LS-
DYNA output files to TenGun, in addition to “d3plot”. 
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Output File Formats 

CAD Files 

TenGun can write IGES, STEP, STL, VTK, VTP, and X3D or X3DB file formats.  
This is useful for two purposes: 

 

• Save your Assembly as you build it.  

If you need modify your data later, 
the saved assembly is your backup. 

• Export your Assembly in a different format for use with another 
application. 

 

 
STEP and IGES files can contain multiple parts. 

 
As for STL: 
 

• STL files can only contain a single part.  Therefore, if you try to save a 
multi-part assembly in STL format, TenGun will create multiple files with 

“-1”, “-2”, etc. appended to the output file name that you specify. 

• If you export a STEP or IGES file as STL, the output will consist of a 

multitude of triangles.  You cannot import an STL file and expect to then 
convert it back to the same STEP or IGES object because original 
connectivity information is lost in the export process. 

 
STL, VTK, and VTP files are by default written in binary format.  Select the 

Save as Text   on the “Save Assembly As” dialog to write the files as ASCII Text. 

 

Finally, TenGun can export an assembly as an X3D (.x3d) or X3D Binary 
(.x3db) file.  X3D is the successor to VRML.  At this time we cannot read X3D 
files, so we do not claim that we can convert between this and other formats. 

 

Analysis Application Data Files 

TenGun can convert your assembly to a data file suitable as input to an analysis 
application.  Requirements for this are specific to that analysis application and 
are documented separately. 

  

Menu:  File ➔ Save Assembly. 
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Point Data Export 
 Time Series point data can be saved in a text 

file using File ➔ Export ➔ Selected Point Data. 

This function saves the currently displayed (i.e., 

filtered) data, allowing you to export a subset of 
a Time Series for use in another application.  

The default settings will create a CSV file that 
can be immediately loaded into a spreadsheet. 
 

You may save the data as a CSV (default), DAT, OBJ, PLY, STL, VTK, or VTP 
file.  By default, the output is written as ASCII text. You can also save PLY, STL, 

VTK, and VTP files in binary format by unchecking the  Save as Text  option.   
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Screen Layout & Navigation Tricks  

Below is a screenshot of TenGun in action. 

 

TenGun User Interface Layout 

 
 
Key elements of the User Interface (numbered in red) are: 
 

1. Menu Bar.  Sub-menus are: 
 

• File.  File-related operations and Exit.  There are additional items 
when in Assembly Mode. 

• Edit.  Some editing operations. 

• Camera.  Change the viewpoint. 

• Object.  Create CAD objects and modify object properties in 

Assembly Mode. 

• Tools.  CAD object and Point Cloud utility functions, for example, to 

edit geometry. 

• Charts.  Create charts. 

• Window.  Change window settings. 

• Help.  Display help documentation and program information. 

 
2. Toolbar.  Contains buttons you can click to perform some common 

operations instead of using the menus. 

3. Tree View.  There is one root entry for each Panel Tab. You may edit the 
name corresponding to a Panel Tab; this will also update the name on 

the Panel Tab. 
4. Panel Tabs.  One tab per set of files.  There are two tabs in this example. 
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5. Scene Panel(s). Each panel represents the graphics window for one set 

of files, with two panels shown here.  See Hints at the end of this section 
for how to display panes side-by-side.  

6. File Browser (Experimental Feature).  This control lets you browse 
through the file system for your data.  There are three parts: 
 

• At the top is a dropdown list of the folders you have most recently 
accessed from TenGun.  Using this list is often quicker than 

navigating the folder tree.  The folder you select may sometimes 
appear near the bottom of the tree view. 

• The middle portion shows tree-structured view of the file system 

that you can navigate using either the mouse or the keyboard. 

• At the bottom is a list of file extension filters that you can use to 

limit the output. 
 

7. Message Window.  TenGun logs informational messages in this area. 
8. Status Bar.  Shows some User Interface status messages.  Of particular 

interest is the bottom right corner which displays “File n / m”, indicating 

the progress of file reading operations. 
 

Hints 

• You can change the width of the File Browser by dragging the vertical bar 

sideways. You can also entirely hide this from the Window ➔ Show File 

Browser menu item. 

• When you have multiple files and 
multiple panels open you can navigate 

as follows: 
 

o To change panels, left-click a 
Panel Tab, or click on the 
corresponding item in the Tree View. 

o To jump directly to a specific Time Series item, left-click on the 
item in the Tree View. 

o To go to the next item in a Time Series view press  n  ("Next"), 

and to go to the previous item press  N  ("Shift Next"). 

 

• For a Time Series, Panel Tab title includes “#1”, “#2”, etc. as a hint to which 

file in the series you are currently viewing. 

• A different icon is displayed in the Tree View for Time Series data ( ) and 

Assembly Mode data ( ). 

• To combine scene panels for a side-by-side view, drag the tab for one panel 

to the left, right, or bottom edge of the target pane. The target pane will be 
split so that you can see multiple models in a single panel. 

Keys: 

 n : Next frame. 

 N : Previous frame. 
 

Toolbar: Next:  Previous:  
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• To split scene panels, drag the tab for one panel into the Tab Bar. The 

combined model views will be split into individual panels. 

• With scenes in a side-by-side view, you can scroll the scenes in parallel by 

clicking the  (“Synchronize Scenes”) button on the toolbar.  This is very 

handy for seeing how different data fields are related. Click the button again 
to disable parallel scrolling.  When parallel scrolling is enabled the icon 

changes from green to red. 

• Sometimes you want to compare two sets of results, so you open lots of files 
with similar names, but from different folders. You can get totally confused, 

just by the names, and you can make it worse if you drag two tabs so that 
they appear side-by-side in the same window. 

 
To avoid such confusion, first load one set of files. Next, left-click the scene's 
root item in the Tree View. Wait a second, and click again so that the label 

will enter edit mode. Change the label to something better than the file name 
such as "Old". Changing the Tree View label will also change the tab label. 

Now repeat this for the other set of files, but use a different label such as 
"New". Confusion over the file names is now gone even if you rearrange the 
tabs. 
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Time Series Mode (Post-Processing) 

Analysis applications typically generate a number of time step-based particle 

(point) output files. The output contains particle positions, velocities, pressure, 
temperature, and other relevant analysis results. TenGun is then used to 

visually verify those results. 
 
Post-processing features include: 

 

• Flexible input file handling. 

• Filter values using field name and range expressions to display specific 
details. 

• Cut (slice) the results one or more times so that you may inspect the 
inside of the model. 

• Emphasis on ease-of-use, and without a bloated User Interface. 

• Easily create analysis presentation material. 

• Animated playback.  Play back a series of analysis output files. 

• Create a movie file from the animation output. 

• Automated report creation. 

• Multiple chart types:  Frequency Distribution (bar chart or line chart), Line 
Chart, Scatter Diagram, and Timeline with statistics. 

• Save Screenshot to file. 

• Copy Screenshot to Clipboard for immediate use in another application. 

• Easily customizable "Display Profiles" that allow definition of user-
specific input file layouts, colors, labels, and other settings. 

• High-performance, even with large datasets. 

• Multi-lingual.  English and Japanese are currently available. 

 
To use Time Series mode, we suggest that you next review the User 
Interface chapter which follows.  
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User Interface 

This section describes key features of the user interface. 

File Open 

To open a file in the Text Editor, navigate to the File ➔ Open text file dialog. 

 
To open a file for Time Series or Assembly mode display 

do one of the following: 
 

• Double-click a file name in the built-in File 

Browser, or 

• Select multiple files in the built-in File Browser 

and press  Enter . 

• Drag and Drop a file from another application 
such as Windows Explorer, or 

• Navigate to the File ➔ Open data file dialog.  Select the file(s) and select  

OK .  

 

To select multiple adjacent files, hold the  Shift  key while picking them; to 

select multiple non-adjacent files hold the  Ctrl  key while picking them. 

 
Next, TenGun will display the File Processing Options dialog: 

 

 
 
The File Processing Options are: 
 

• Display Profile. If you are just starting, try the 
"Default" profile. Later, you will learn how to 

customize the display parameters. Display Profile 
settings apply mainly for Analysis Output files, 
and are especially important if processing "dumb" 

Keys:  Ctrl+O . 
 

Menu: File ➔ Open 
data file. 
 
File Browser:  Double-
click. 
 

Toolbar: . 

 

If a CSV or DAT file 
does not display, you 
may need to customize 
the Field definitions in 
the profile. 
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input files containing no field information. For CAD files the profile mainly 

only affects the coloring, so you may choose any profile. See also 
Automatic Profile Selection below. 

• Generate IDs.  Check this to enable the automatic creation of Point ID 
data. When your analysis is misbehaving, it is sometimes helpful to filter 
by the ID so you can display the properties of particular particles. 

• Load as separate parts.  If this option is checked, CAD files loaded in 
Assembly Mode will be treated as separate parts, and each part can be 

modified and manipulated with TenGun ’s geometry-related tools.  If 
unchecked, multiple parts are combined into a single object.      

• Use Extended Reader.  This option currently applies only to OBJ and 

STL files.  The default readers are fast.  However, to use OBJ or STL 
data with Boolean Operations and other advanced Assembly Mode 

features you must use the slower “extended” readers. 

• Use Background Image.  Check this to use the background image as set 

in the profile.  This is disabled by default because under normal usage it 
is rather obtrusive.  However, you may want to use a background image 
when creating presentation materials. 

• Read every nth value. This option skips some of the input when 
processing text input files.  A value of ”1” reads all input, but a value such 

as only ”5” reads only every 5th value.  This is a great speedup, and can 
save a lot of memory if you working with huge data files. 

• View.  Select the display mode:  Time Series, Assembly, or Text Edit as 

appropriate.  The available operations depend on this mode, so 
remember to select the correct mode.    

• After selecting  Load  or  Append , TenGun tries to read the data.  Upon 

a successful read, the Load option displays the data in a new scene 

panel, while the Append option adds the data to the current panel. 
 

Automatic Profile Selection 

If you work with many different output file formats, you can set TenGun to 

automatically select the correct profile based on a file name pattern.  To use this 
feature: 

 

• Create a text file name C:\ProgramData\TenGun\ProfileMap.dat. 

• Add one line for each file pattern that you use.  Each line should contain 

a regular expression (a wildcard pattern) to match the name, a space, 
and the name of the profile.  For example: 

 
    Out-Flow-…..\.dat Flow 
 

The first five periods match any character.  The “\.” is an escaped period, 
so instead of matching anything, the next character in the file name must 

be a real period. When you try to open a file matching this pattern, 
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TenGun will automatically select the profile named “Flow” in the File 

Processing Options dialog. 
 

Blank lines and lines beginning with ”#” in ProfileMap.dat are ignored.  Also, th is 
feature does not currently support international characters in the name pattern 
or the profile name. 

 
 
 

Notes 

• The number of files you can open is limited only by the available memory. 

• When TenGun displays Time Series data, the camera is positioned such 

that the entire scene is visible, and the focal point is the center of the scene.  
This works fine if the bounds of the scene are the same in each time step.  
However, some data is unconstrained (especially Discrete Element Method 

output), and the scene boundaries are different at each time step.  In this 
case, the camera would need to be moved at each time step, but that would 

result in rather strange animations.  TenGun solves this by computing the 
overall bounds of all scenes.  When the last file of a series is loaded, 
TenGun may redraw the currently visible scene to adjust the camera 

position, so don’t be surprised if the current scene suddenly appears to 
shrink. 

  

Fields 

 To view details for particle data, select the field name in the "Field" dropdown 
list. TenGun will then display a Scalar Bar. For scalar values you can then see 

the range of values (e.g., for Density or Pressure), and for discrete variables 
you can see the corresponding color legend (e.g., which color represents fluid 
or various solid objects).  

Field Handling Rules 

• Field name matching is case-insensitive.  Field names may contain 
alphanumeric characters and “_”.  However, you should avoid using “_” 
at the beginning of a name to prevent possible conflicts with TenGun 

internal data. 

• Extra fields in a Profile that are not used in a particular input file are 

ignored. You may want to keep extra field definitions in case you work 
with a variety of similar data.  

• If a CSV input file contains an undefined field, TenGun will automatically 
add it (temporarily) to the Profile as a float vector. If this is an 
inappropriate type, please add an appropriate field defin ition.  

• X, Y, and Z (particle positions) are required input fields. These are 
implicitly defined in the Profile with a Data Type of " float". 



 

TenGun User Guide – 15  

• Maximum line size for text input is 4096 bytes; lines are typically 200 

bytes long or less. 

Pan, Rotate, and Spin  

You can pan, rotate, and spin the model 

using the mouse. Mouse button usage 
depends on the type of mouse, but the 

Left Button is used for rotation in all 
cases.  
 

Zoom 

You can zoom in or out using either keys or 

the Toolbar buttons. 
 
 

Camera Position 

Use the keys and the Camera Menu to 
quickly move camera around. 

 
The Rotate actions “x” and “y” rotate the 

camera 10 degrees counterclockwise 
about the respective axis, while “X” and 
“Y” rotate clockwise. 

 
The  (“Home”) button on the Toolbar 

can also be used to undo all edits, reset the zoom level, and reset the camera 

to the front view.  
 

  

Keys: Zoom In:  + , Zoom Out:  - . 
 

Toolbar: Zoom in: , Zoom out:  

Keys:  Top:  Ctr+T, Left:  Ctrl+L, Right: 

Ctrl+R, Front:  Ctrl+F, Rear:  Ctrl+E, 

Bottom:  Ctrl+B, Rotate +X:   x , 

Rotate -X:  x , Rotate +Y:  y , Rotate -Y:  y . 
 

Menu: Camera ➔ Front, Left, Right, Top, 
Bottom, or Back. 
 

Toolbar: . 

You can access a Quick Reference guide in 
the TenGun Help menu that describes 
mouse operation as well as summarizing 
keyboard actions.  
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View Features and View Type 

Use the View menu to display a model 
view mode: 

 

• Points.  Display the model as 

points (pixels). 

• Spheres.  Display the model as 
spheres.  Spheres in general look 

cuter than points, but require 
more processing power to draw. 

• Solid.  Display a CAD model as a 
solid object. 

• Vectors.  See discussion below. 

• Wireframe.  Display a CAD model as a wireframe. 

• Bounding Box.  Add a bounding box around the data.  This is sometimes 
helpful in visualizing particle flow if the data is not constrained by a 
container. 

• Lighting.  Toggle lighting effects. 

• Scalar Bar.  Enable or disable display of the Scalar Bar. 

 
You can use the Point Size control on the Toolbar to change Point and Sphere 

sizes. Make the points larger to fill in gaps, or make them smaller to peek inside 
the model.  
 

Vector View 
 This view displays a field as a scaled vector instead of a point or sphere. 

 
Individual fields may be combined into 2D or 3D vectors.  For example, the 
three fields VX, VY, and VZ can be combined to create the 3D velocity vector.  

These vectors are defined in the General Profile settings.  Individual 
components of the vector are separated by commas (e.g., “VX, VY, VZ”), and 

multiple vectors are separated by semicolon (e.g., “VX, VY, VZ; StressX, 
StressY, StressZ”). 
 

Usage is then as follows: 
 

• Select the View ➔ Vectors menu item or press  v   v  . 

Choose the vector to use. 

• Set a scale value. 

• Select  OK . 

 

TenGun then normalizes the selected vector magnitudes to the range 0 to 1.  
For each field value, a line is drawn from the field’s position in the direction of 

Keys: 

  v   b :  View Bounding Box. 

  v   h :  View Spheres. 

 v   p :  View Points. 

  v   s :  View Solid. 

  v    v :  View Vectors. 

  v    w : View Wireframe. 

  s   s :  Toggle Scalar Bar display. 
 

Menu: View ➔ Bounding Box, Points, 
Spheres, Solid, Vectors, or Wireframe.  Also, 
Lighting, Scalar Bar. 
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vector.  The length of the vector is controlled by the “scale” value in the settings 

dialog.  Note that the scaled vector length is in “World Coordinates”, so you may 
need to make the scale value small if the particles are small. 

 
In general, you use coloring to highlight features of your data such as 
temperature or density.  The Vector View feature can sometimes be combined 

to make interesting graphics that show not only something like temperature, but 
the particle flow. 

  



18 – TenGun User Guide 
 

Filters 

 Filters allow you to display a subset of the input data. To apply a filter, enter a 

Filter Expression in the Filter area on the Toolbar and press  Enter . TenGun 

remembers your most recent filters, which you may select from the dropdown 

list instead of typing the expression again.  
 

A Filter Expression is of the form: 

field relop constant 

where: 

• field is a Field Name. Field names are case insensitive. 

• relop is a relational operator: < (less than) <= (less than or equal), = 
(equal), != (not equal), >= (greater than or equal), and > (greater than).  

• constant is a constant numeric value. 

 
Examples: 

Pressure > 1.5 

Material = 3 

You may use multiple expressions by separating them with the logical operators 

"and" and "or". For example: 

material != 1 and density > 0.95 

Expressions are evaluated left-to-right. You may currently not group sub-
expressions using parentheses. 
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2D Cut 

 You can look inside a model using the 2D 
(Plane) Cut feature: 

 

• Select one of the Cut directions as 

shown in the sidebar. 

• A yellow plane is displayed 
perpendicular to the cutting direction.  

There are two ways to move the cutting 
plane: 

o Left-click and drag on the plane.  
This method easy and helpful 
when you just need a rough cut.  You may need to rotate the 

model slightly in order to grab the plane. 
o Or, directly set the boundary 

values in the “Plane Cut” dialog.  
This method can be used when 
you need a more precise cut. 

• A normal vector is also drawn through 
the plane pointing in the direction of the 

portion to be preserved after the cut.  

• You can rotate the cutting plane by dragging one of the cones on the 

ends of the normal vector. 

• Press  Enter  to complete the cut, or press  Esc  to cancel. 

• Undo a cut operation by typing  Ctrl+Z s or from the Edit ➔ Undo menu 

item.  
 

The 2D Cut feature is currently not available in Assembly Mode. 

2D Cut Example 

The image on the left shows show the screen after typing the  c   X  (“Cut right”) 

command.  The cut will be made at the Clipping Plane, and the portion in the 
direction of the Normal Vector is preserved.  The image on the right shows the 
result. 

 

 
 
  

Keys: 

 c   x : Cut left. 

 c   X : Cut right. 

 c   y : Cut below 

 c   T : Cut above 

 c   z : Cut front. 

 c   Z : Cut rear. 

 i  : Invert cut direction. 
 

Toolbar:  for cx, cy, and 
cz.  Press Shift while clicking to 
use cX, cY, or cZ. 
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3D Cut 

 The 3D Cut feature allows you to cut out 
portions of an object so that you may view the 

inside.  To use this feature: 
 

• If you are in Assembly Mode, select the 
object of interest by Right-clicking it. 

• Type  c   v  (“Cut Volume”). 

• A bounding box is displayed around the object and the “Volume Cut” 
dialog is displayed. 

• There are two ways to select the desired volume: 

o Use the six round “handles” on the outsides of the bounding box.  
Left-click and drag any of the handles to move the associated face 

in or out.  This method easy and helpful when you just need a 
rough cut. 

o Or, directly set the boundary values 

in the Volume Cut dialog.  This 
method can be used when you need 

a more precise cut. 

• Type  i  (“invert”) to toggle the selection 

direction.  This allows you to keep the 

outside of the bounding box instead of the 
inside. 

• When you have enclosed the area of 

interest, press  Enter  or click the OK button.  To cancel the operation 

press  Esc  or click the Cancel button. 

• Undo a cut operation by typing  Ctrl+Z  or from the Edit ➔ Undo menu 

item. 

 

Hints 

• 3D Cut is especially useful when creating Point Cloud.  Some portions of the 
model can often be removed to reduce the number of particles in the 

analysis without having any effect on that analysis. 

• In Time Series Mode, a 2D-Cut is applied to all members of the Time Series.  
At this time, a 3D-Cut in Time Series Mode is applied only to the current 

Time Series item.  This behavior is likely to change in a future version so 
that the cut is applied to all Time Series items. 

3D Cut Example 

The left image shows an exhaust manifold with 3D-Cut actve.  The top and the 

rear handles are moved down and in to remove the flanges.  The right image 
shows the result after cutting. 

Keys: 

 c   v : Cut Volume. 

 i :  Invert cut direction 
(toggle between inside 
and outside). 
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Screenshots 

You can make screenshots in the 
following ways: 

 

• Press  Ctrl+S . You will be 

prompted for the name of a file to 

save the screenshot in. You may 
also select the file format (BMP, 
JPEG, PNG).  

• Press  Ctrl+C . The screen image 

is placed in the Clipboard, and 
from there you may paste the 

image into some other documentation.  
 

Animation & Movies 
 

 To create an animation: 
 

• Open two or more files. Analysis 
programs typically create the output files 

with a sequence number such as output001.csv, output002.csv, etc. 

• The first file will be loaded immediately, 
and additional files will be loaded in the 

background.  NOTE: You can see the 
file loading progress by observing the 

Status Bar. The bottom right corner of 
the screen shows a load progress 
message, such as "File 15 / 20", which 

indicates that 15 out of 20 request files 
have been loaded.  

• Optionally set a custom title message. See Animation Settings. 

• Type a or click the  (“Play”) button on the Toolbar. This functionality is 

disabled until at least two files have been loaded. 

• The first time a file is displayed, TenGun will display the underlying 
graphic data, and it will also create an image file of that data. If you 

continue playing the animation, the image file is displayed instead of the 
graphic data, which is considerably faster. The first pass is therefore 
likely to be relatively slow, but subsequent passes are more likely to 

match the per-scene Animation Time that you have specified.  

• The Animation playback time can be set in the Animation Settings. The 

default time is 200 milliseconds between screens. 

• To stop playback press  Esc , or press the Stop Animation button in the 

Toolbar. 

 
To create a movie: 

Hint: Screenshots taken on a wide screen 
will generally have a lot of empty space. We 
suggest that you resize the TenGun window 
so that the scene area has an aspect ratio 
of approximately 4:3 (1.333).  This aspect 
ratio is displayed in the Message Window 
as you resize. 
 
This advice also applies to creating reports 
and animation.  Use the Window → Reset 
Window Layout menu item to restore the 
size to the default. 

Keys:   a   to start,  Esc  to stop. 
 

Toolbar: Start:  Stop: . 

Image files are stored in the 
"TenGun_Animation_datetime" 
subfolder where the input data 
resides. This folder will be deleted 
whenever you open a new input 
file or when you exit TenGun. If 
you want to keep the bitmaps, 
copy them before you do one of 
these actions.  
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• First create the animation data as described above. 

• Select the File ➔ Save Animation as Movie menu item. 

• Enter the movie file name.  The file type can be “avi”, “mp4”, or “ogg” as 
indicated by the file extension.  The “mp4” and “ogg” formats are 

supported in a web page in a <video> control.  The “ogg” format tends to 
be the smallest but is not supported by Safari as of this writing.  If you set 

the type to “all”, TenGun will create movies in all supported formats. 

• Select OK to create the movie. 

 

Notes 

• When animation starts, the Scalar Bar range for continuous variables is 
calculated from all of the data that has been loaded so far.  This is done 

so that the Scalar Bar shows the variable range for the entire simulation 
rather than the range for individual scenes.  If the exact range is 
important to you, you must wait until all files have been loaded. 

• The default “on” behavior is to use the overall minimum and maximum 

values from all scenes in the Scalar Bar.  The  s   a  command can be 

used to toggle this behavior.  When “off”, the minimum and maximum of 
individual scenes is used instead. 

• While animation is active you may not perform any actions that affect 
scene layout such as zoom, filter, and so on. Therefore, you should set 

up the display exactly as you want it before you start the animation.  

• TenGun creates movies by running the command file 
“C:\ProgramData\TenGun\CreateMovie.cmd”.  This command file is 

responsible for running a separately installed third-party application such 
as the open source FFmpeg.  This application then converts the 

animations images created by TenGun into the desired movie file format.  
Feel free to customize this command file to meet your requirements. 
 

Some media players including Windows Media Player or VLC 
automatically play a movie when it is opened, and often do not display 

the very beginning.  If this occurs, rewind the movie and replay from the 
beginning.  This problem does not occur with the ffplay player included 
with FFmpeg. 

  

https://ffmpeg.org/download.html
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Charts 

 You can create these types of charts: 

 

• Distribution Chart.  This calculates a Frequency Distribution and displays 

it either as Bar Chart or a Line Chart. Multiple variables may be selected.  

• Line Chart. You may plot a single variable along X-Axis to plot against 
one or more variables on the Y-Axis.  Either axis may be plotted using a 

logarithmic scale instead of the default linear scale, although the internal 
charting code may sometimes override your choice.  

• Particle History.  This plots time-series values for one or more variables 
and one or more particles. For points you may specify: 
 

o A single point. Point IDs start at 1. 
o A point range where the values separated by a hyphen (e.g. 2000-

2005). 
o Multiple points or point ranges separated by a comma (e.g. 

100,200-204,300). 

 
The point set is initialized to the most recent five points that you have 

selected with the Point Picker. 

• Scatter Diagram.  Same options as for Line Chart, but X-Y pairs are 

presented as dots instead of lines. 

• Timeline Chart.  This plots a time-series for one or more variables for the 
selected statistic(s).  Available statistics are average, maximum, 

minimum, and standard deviation.  This chart is useful for f ields such as 
Equivalent Stress where only the maximum value is actually useful. 

 
 
To create a chart: 

 

• Open a Time Series view.  Particle History and Timeline Charts require 

that you open multiple files. 

• Select a chart type from the Charts menu.  The data source is in the 

Time Series data, so you cannot select a chart type from an Assembly 
Mode or from a Chart view. 

• Fill in the parameters appropriate to the chart.  Minimally this involves 

selecting the field(s) to be displayed in the chart. 

• Select  OK .  The chart is displayed in a new tabbed pane. 
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Timeline Chart Example 

The following shows the setup dialog for a Timeline Chart for a stress analysis 

and the resulting chart. 
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Reports 

 TenGun can create a report, with graphics, of your data.  To do so: 

 

• Open a file or a file series. 

• Optionally set a Filter. 

• Select the File ➔ Create Report menu item. 

• Enter a report file name and optionally a description.  The description is a 
good place to enter notes about conditions used for this analysis. 

• Select the file type for image files (BMP, JPEG, or PNG). 

• Select the fields you wish to report on. 

• Select one or more object faces to be used to create graphics (Front, 
Back, Left, Right, Top, Bottom). 

• Check "All Scenes" to include all scenes of the time series in the report. 

If unchecked only the current scene is included.  

• Select  OK . 

 

TenGun then moves the camera as required, cuts the model in half, and takes a 
screenshot for each selected face. 

 
The generated report file can be viewed by any HTML5-compatible browser. 
 

Report Setup Example 

The Report Settings dialog is shown below. 
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Object Picking 

TenGun provides the following object 
picking behaviors: 

 

• Points.  The Point Picker displays all 

properties for the nearest selected 
point in popup "balloon".  (To hide 
the balloon, move the mouse 

pointer.)  Use the Zoom, Rotate, and Cut functions as necessary if you 
actually need to pick a specific point.  

• Edges.  Pick edges of a CAD model. 

• Faces.  Pick faces of a CAD model. 

• Vertices.  Pick vertices of a CAD model. 

• Object.  Right-click an object in Assembly Mode to select it, and the 

object is then highlighed. You may use the Geometry Editor to change 
position, scale, and rotation of individual objects.  And, you may combine 
multiple objects using Boolean Operations.  You may also select objects 

via the Tree View, which is sometimes helpful when one object obscures 
another object. 
 

To select multiple objects, press  Shift  while clicking.  To deselect an object, 

click it again. 

Hints 

• To rotate an object while picking is enabled, move the mouse pointer outside 
of the object to a blank area. While pressing the left mouse button, move the 

mouse point to rotate the object. 

Hide Object 

You may sometimes wish to hide an object, especially when you want to edit 

one object contained inside another object.  To do so: 
 

• Navigate to the object that is in the way type typing   n  ("Next"), N  

("Shift Next" for previous), or by clicking the object in the Tree View. 

• Type  h   (“Hide”). 

 

To restore visibility, navigate to the hidden object and type   h  again.  You can 

also unhide the object by clicking it in the Tree View. 

 

  

Keys:  p   p  (pick points),  p    e  (pick 

edges),  p    f   (pick faces), or  p    v   
(pick vertices) to enable picking mode,  

Esc  to turn off picking. 
 
Mouse: Left-click to pick a point, edge, or 
face. Right-click to pick an object.  To 

select multiple items hold the  Shift  key 
while clicking. 



28 – TenGun User Guide 
 

Pick Interior Face 

Sometimes you need to select an interior 
face of a CAD object so that you can set 

properties such as a boundary condition.  
To do this, first enter Pick Face mode as 

previously described.  Next, you normally 
click an exterior face.  However, to select 
the “nth” face behind that exterior face, type 

a number (1 to 9) before clicking the 
exterior face.  The most common case is 

that you type “1” to select the inside of a wall, and from there you can set 
properties for that inside wall using Edit Part Properties (refer to Assembly 
Mode (Pre-Processing) for details on setting part properties).  Ordinary behavior 

is restored by typing “0”, or by restarting Pick Face. 

Distance Measurement 

Use the Distance Measurement feature to 

find the distance between two points: 
 

• Start or restart measure mode by 

pressing  m . 

• Click the starting point. 

• Move the mouse pointer and click again to establish the second point along 

a “ruler”. 

• TenGun “snaps” the points you selected with the mouse to the nearest 

points in the actual points in the data and displays the distance. 
 
 

 
 

 
 

  

Keys:  m .  Press  Esc  to turn off 
measurement. 
 
Mouse: Drag the handles of the ruler to 
move the two endpoints. 
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Profiles 

A "Profile" contains information describing Field 
properties such as the data type (e.g., integer, float), 

labels for scalar bars, and coloring information. 

General Settings 

 
 
Settings are: 

 

• Text Color. The color for text messages. Double-click the color to display 
a Color Picker Dialog. 

• Background Color. The background color for text messages. As above, 
double-click the color to change it. 

• Background Image.  The name of an image file that can optionally be 
added to Time Series displays.  Whether or not this is actually used is 

determined by an option in the File Processing Options dialog. 

• Font Name. The name of the font to use. Most TrueType™, OpenType, 
and FreeType fonts can be used. (Some of these do not work with the 

graphics library, so you may have to experiment a bit.)  Double-click the 
font name to change it.  

• Point Color. This is the color to use for points when a color table is not 
assigned. 

• Selected Object Color. This is the color to use for selected vertices, 
edges, faces, and objects. 

• Unselected Opacity.  When an object is selected, the opacity of the other 

objects can be changed.  This allows you to see the selected object 
through any containing objects.  The value range is 0.0 for fully 

transparent to 1.0 for fully opaque. 

• View Type. Sets the default point view type such as Points or Spheres. 

• Point Size. Sets the default point size from 1 to 99, with 1 through 10 
being common. 

Menu: Edit ➔ Settings. 
 

Toolbar: . 
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• Default Field List. This list defines the names of fields for simple data 

files that do not contain any field definitions.  Field names are separated 
by commas. 

• Default Field Name. If this item is set, TenGun will automatically select 
this field whenever you open a file using this profile. 

• Size Field Name.  TenGun supports variable point size display which is 

useful for displaying Discrete Element Method (“DEM”) and Molecular 
Dynamics results.  The Size Field Name is the name of a field in the 

output data containing the particle size, for example “Radius”. 
 

To display such data, TenGun converts individual points into spheres of 
the associated radius.  Additionally, TenGun clones properties from each 
particle such that if you do Point Picking anywhere in the sphere, it will 

report the information for the original field data.  The “Point Number” 
displayed will no longer match because there are now more points.  

However, if the input data has an “ID” field, the original ID will be correct 
no matter where you click on the sphere. 
 

This feature can generate a significant amount of additional data, so it is 
not intended to be used with huge point clouds. 

• Point Quality.  The value sets the number of subdivisions used to create 
the graphic representation of each sphere.  A setting of about 5 ~ 10 is 
not beautiful, but reasonable when you are just verifying your analysis 

run.  Then, before for making presentation material you can raise this to 
a higher value such as 20.  Note, however, that this setting only takes 

effect for newly loaded data, so you cannot change it for a scene that is 
already being displayed.  If the Point Quality is set to 0, TenGun uses the 
normal Point Size setting to display a scene, and ignores the “Size Field” 

setting.  Finally, for higher quality output, you can display the scene using 
a Solid View instead of the usual Sphere or Point View used for particle 

data. 

• Vectors.  Vector definitions for Vector View mode.  Refer to Vector View 
for details. 
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Continuous Scalar Colors Settings 

Scalar Color settings are used when 

displaying the Scalar Bar for continuous 
variables such as Density or Pressure. 

 
 
 

 
 

Settings are: 
 

• Table.  Used to select a specific Scalar Color Table. Use the Add Table 
Button to add a new table, and use the Delete Table Button to delete the 
selected table. 

• Color for Minimum Value.  Scalar colors are based on a color wheel 
concept.  Red, Green, and Blue are at 0, 120, and 240 degrees 

respectively, wrapping back to Red at 360 (0) degrees. The "low" and 
"high" colors therefore select the starting and ending points on the wheel. 

Double-click the color to display the Color Picker Dialog. 

• Color for Maximum Value.  The "high" color as explained above. Double-
click the color to change it. 

• Number of Colors.  Sets the total number of colors. A color gradient with 
this many entries (e.g., 64 colors) will be created for values between the 

minimum and the maximum. 

• Scalar Bar Labels.  Sets the number of labels to display on the Scalar 

Bar when using the Default Scalar Color Table. 

• Scalar Bar Label Format.  This specifies how floating-point values are to 
be displayed. See Scalar Bar Label Format below. 

  

Note: The Scalar Bar Labels and Scalar 
Bar Label Format on this screen apply to 
the Default Scalar Color Table. The 
equivalent settings for the non-default 
case can be made on a field-by-field basis 
in the Fields editing screen.  
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Scalar Bar Label Format 

A format specifies how floating-point values 

are to be displayed, and must be of the form: 
 

[flags][width][.precision]specifier 
 
where: 

 

• "flags" are optional modifiers. "+" forces the display of a plus sign for 

positive numbers, and "-" causes the output to be left-justified. 

• "width" specifies the minimum display width. If the formatted string is 

shorter than this it will be padded with spaces. 

• "precision" specifies the number of digits to display after the decimal 
point. 

• "specifier" specifies a style. Styles can be: e (scientific notation), f 
(decimal floating-point), or g (best fit). "Best fit" means use floating-point 

format if there would be many trailing zeros, otherwise scientific notation.  
 
The default format is "-6.5g". 

  

Users familiar with "C" will notice that 
this is a "printf" format string without 
the % sign. 
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Discrete Colors Settings 

Discrete Colors Tables are used when there are a limited number of possible 

values for a field. For example, an analysis model typically has only a few 
different materials.  In this case you can use a Discrete Colors Table. This maps, 

one-to-one, each material to a different color.  Materials are then easy to 
distinguish during visualization. 
  

 
 

Settings are: 

 

• Table. Used to select a specific Discrete Colors Table. Use the Add 
Table Button to add a new table, and use the Delete Table Button to 

delete the selected table. 

• To add a predefined color set, click the Presets Button and select one 

of the many predefined color tables.  

• To add colors individually, click the Add Color Button. 

• To delete a color (1) select it by clicking the color number in the left 
column, and (2) click the Delete Color Button. 

• To change a color, double-click on it. The Color Picker Dialog will be 

displayed. 

• Opacity. Values can range from 0.0 (totally transparent) to 1.0 (totally 

opaque). You may be able to obtain some interesting display effects 
for your scene by changing this value. For example, if you have a 

scene with water and gas bubbles, you can lower the opacity for the 
water so that the gas bubbles are more visible. Double-click a value 

to change it.  Then press  Enter  to complete the edit, or  Esc  to 

cancel. 
 

In this sample screen we have already added a Field named “Material” on the 
Fields tab, and here in the Discrete Colors tab we define the color scheme for 

material 1 through 4.  
 
  



34 – TenGun User Guide 
 

Field Settings 

This screen is used to define the details of data fields in your input files. 

 

 
 
Settings are: 

 

• Field.  This dropdown list contains the names of available fields. The 
sample profiles contain a number of common fields such as AX, AY, and 

AZ for acceleration, VX, VY, and VZ for velocity, and so on. Use the Add 
Field Button to add a field, and use the Delete Field Button to delete a 

field.  

• Description.  An optional description of the field. 

• Display Text.  If this is set, this text will be displayed in various places 
instead of the field name. For example, if you have a field named "P", 
you might want to actually display "Pressure".  

• Content Type.  The selected value indicates how this item is related to 
the model, for example, the data is related to "Acceleration", "Velocity", 

"Stress", etc. This is currently unused, but may be used in a future 
version to provide additional analysis capabilities.  

• Content Detail. This specifies the English name of the content. It is 

currently used in handling variable particle sizes so that we can 
determine that the field named “R” is actually a radius, or the field named 

“Phi” is a diameter. Allowed values are “Radius” and “Diameter”. 

• Data Type.  Specifies how the data should be stored internally. Possible 

settings are: 
  

o byte.  8-bit unsigned integer. Range: -128 to +127. 

o double.  64-bit floating-point. Range: 2.225 E-308 to 1.797 E308 with 
approximately 15 digits of precision. 

o float.  32-bit floating-point. Range: 1.175 E-38 to +3.402 E38 with 
approximately 7 digits of precision. 
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o int.  32-bit signed integer. Range: −2,147,483,648 to 

+2,147,483,647. 
o long.  64-bit signed integer (in "C" this is really called a "long 

long").  Range: -9,223,372,036,854,775,808 to 
+9,223,372,036,854,775,808 

o short. 16-bit signed integer. Range: -32768 to +32767. 

o string.  A character string in UTF-8 format.  Currently of limited 
use in TenGun. 

o uint.  32-bit unsigned integer. Range: 0 to 4,294,967,295. 
o ulong.  64-bit unsigned integer. Range: 0 to 

18,446,744,073,709,551,615. 

 
To conserve memory you should try to use Data Types that are as small 

as possible but still contain the range of your values.  
 

• Discrete.  This option can be used for fields that contain a limited number 

of different values. (Up to about 10 is reasonable). This option instructs 
TenGun whether to use Scalar or Discrete Colors Table.  

• Scalar Bar Labels.  Number of labels to display on a Scalar Bar for this 
field. Please refer to previous discussion. 

• Scalar Bar Label Format.  The display format for this field.  Please refer 

to previous discussion. 

• Scalar Bar Minimum.  TenGun normally 

uses the actual minimum and 
maximum field values to set the Scalar 

Bar range.  You may set fixed limits by 
setting the minimum and maximum 
(see below).  To reset the normal 

behavior, set both values to 0. 

• Scalar Bar Maximum.  Maximum value 

for the scalar bar range as explained above. 

• Color Table.  Use this to select a particular Color Table to apply to this 

field. 

• Units.  You can set the units to display on the Scalar Bar for this variable 
such as “m/s” or “MPa”. 

 
In this screen we have defined a discrete integer field named “Material”, and 

have added labels for each of four possible values. 
 
For discrete variables you can specify value/label pairs.  The value depends on 

your particular data, and will be a field value such as a Material number. The 
corresponding label is displayed on the Scalar Bar. Double-click a label or value 

to change it.  Press  Enter  to complete the edit, or  Esc  to cancel. 

 

When a discrete variable is a floating-point type, the meaning of the “value” 
changes.  Rather than being a fixed value, it becomes an upper limit.  For 

example, for a stress field, you might set values of 0.0 (lower limit), 1000.0, 

When displaying a Time 
Series, you may temporarily 

change the minimum and 
maximum values by 

pressing  s   e .  These 

settings are not saved in the 

profile. 
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2000.0, and 3000.0 (upper limit) to define four ranges that are used to select 

one of four colors from a Discrete Color Table.  Where this becomes interesting 
is if you adjust the opacity in the color table.  For example, to make high-stress 

areas easy to see, set the opacity to lower values (e.g., 0.1) for stress levels 
that you are not interested in, and set the opacity to a high value (up to 1.0).  
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Chart Settings 

 
 
Settings are: 

 

• Text Color.  Color for labels in the chart. 

• Background Color.  Chart background color. 

• Pen Width.  Width of lines in a chart. 

• Color Table.  One color for each possible variable.  If there are more 
variables than colors, colors will be reused starting from the beginning of 
the table. 
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Animation Settings 

 
 
Settings are: 

 

• Animation Time.  The number of milliseconds between animation 

frames. 

• Title.  Text to display in the animation screen. The text may include 

the following macro values: 
 

o %D Current date. 

o %E Elapsed time. 
o %F File name. 

o %P Number of points (particles). 
o %S Animation step number. 
o %T Current time.  

 

• Elapsed Time Scale.  TenGun multiplies the time step number by this 

scale value to arrive at the elapsed time.  In many simulations, one 
output file represents the results after a number of simulation steps.  
For example, the time step may be 1 microsecond, but the data is 

written only every 1000 steps.  In this case the time scale value would 
be set to 0.001 (0.000001 seconds x 1000 steps). 

• Elapsed Time Format.  This is a format string that you will want to 
adjust depending on the Elapsed Time Scale.  For example, for the 
above Elapsed Time Scale example, the smallest time will be 1 

millisecond.  In that case you can set the format to “-4.3f” which will 
display 3 digits after the decimal point.  Refer to Scalar Bar Label 

Format for format string details. 

• Showcase Mode.  After displaying a time series you can rotate the 

camera around the object to showcase the final product.  The mode 
can be either “None”, “X-axis Rotation”, or “Y-axis rotation”. 
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• Angle Increment.  Showcase Mode increment in degrees for the 

rotation.  A positive value moves the camera counterclockwise, and a 
negative value moves clockwise. 

• Maximum Angle.  The maximum angle for Showcase Mode.  This will 
normally be 360°, but can be less for a partial rotation, or more if you 
want to rotate several times.   
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Help 

The following information is available from the Help menu item: 
 

• Documentation.  Displays this file. 

• Quick Reference.  Displays keyboard and mouse usage information. 

• Release Notes.  This contains program update history and known 
limitations. 

• About This Scene.  Displays metadata for the current scene. 

• About. Displays TenGun program and license information. 

 

Additional Documentation 

The following documentation is also available in installation folder under the 
Docs subfolder: 
 

• EULA-eng.rtf. The End User License Agreement. 

• ThirdPartyLicenses.pdf. This file contains license information about Open 

Source libraries used by TenGun.  
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Assembly Mode (Pre-Processing) 

TenGun can create input data for various analysis applications. This typically 

involves converting multiple CAD files to particle format, and then adding 
application-specific parameters such as timing control, material properties, 

boundary conditions, and so on. TenGun encapsulates these pre-processing 
activities with a few simple operations. 
 

Pre-processing features include: 
 

• Read a number of CAD format files including IGES, OBJ, PLY, STEP 
(ISO 130303-203 and 130303-214), and STL. 

• Convert CAD models to analysis-application input format. 

• Convert a CAD mesh to a point cloud. 

• Edit CAD object geometry. 

 
Assembly Mode usage is explained in the remainder of this chapter. 

 
NOTE WELL:  Assembly Mode requires a “Professional” license.  If you do not 

have such a license you will still be able to explore features related to Assembly 
Mode.  However, you will not be able to save any related files. 
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Generating Data 

the s  TenGun can create some basic object 

shapes that can be used to create an analysis 
model.  To do so: 
 

• Open an Assembly view by creating 

and empty view with File➔New 

Assembly or by opening a CAD file in 
Assembly Mode. 

• Insert one or more objects from the 
Object menu.  Available object types 

include: 
 

o Box (Cube).  The box may have 
either one or two open faces. 

o Cone/Frustum. Creates a cone 

or frustum. 
o Extrusion.  Create a 3D object by extruding a 2D surface.  See 

Revolved and Extruded Surfaces. 
o Pipe/Circle. An open-ended cylinder.  You may optionally add 

caps to either end.  Setting the pipe length to 0 will create a 2D 

circle. 
o Revolution.  Create a 3D body of revolution from a 2D surface.  

See  Revolved and Extruded Surfaces. 
o Solid Plate. You will be prompted for the dimensions. One of the 

dimensions can be 0 to create a 2D plate. 

o Solid Disk. You will be prompted for the dimensions. Setting the 
depth to 0 will create a 2D disk. 

o Sphere.  A spherical object (hemisphere by default). 
o Torus.  You can create a full torus by specifying an Angle of 

Revolution of 0° or 360°, or a partial torus by specifying some 

angle in-between. 
o Wedge.  Creates a solid wedge or pyramid-shaped object.  The X 

Min and X Max values specify the top left and top right vertices of 
the face in the X plane.  Similarly, the Z Min and Z Max specify the 
top front and top rear vertices of the face in the Z plane.  If all of 

the X, Y, and Z-related values are the same the result is a cube.  
Changing these values therefore allows you to generate a number 

of different shapes.  For example, you can create a pyramid by 
setting X Min and X Max to half the width, and Z Min and Z Max to 
half the depth. 

 

• Duplicate.  Creates a duplicate of each selected object.  Duplicated 

objects are inserted to the right of the original; from there you can move 
them as required. 

• In addition to inserting objects as described above, you can open a file 

and append it to an existing view. 

Keys: 

 n :  Next object. 

 N :  Previous object. 

 s :  Toggle selection of all 
objects. 

 Del :  Delete object. 

 Ctrl+N :  New Assembly. 

 Ctrl+G :  Edit Geometry. 
 
Menu:  

File ➔ New Assembly. 

Object ➔ Insert Object. 
Object ➔ Duplicate. 

Object ➔ Delete Object. 

Tools ➔ Difference. 

Tools ➔ Intersect. 

Tools ➔ Union. 

Tools ➔ Edit Geometry. 
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• The default size of each object is such that the length, width, and/or 

height are 100mm.  This is a practical size for a part that you might 
analyze with millimeter-sized particles. 

• For many objects you can set a wall thickness that by default will be a 
few particles thick.  For round objects such as a Pipe, the wall thickness 
is implied by the inner and outer radius.  The wall thickness concept is 

used to control the strength of a fixed boundary versus free-flowing 
particles in an analysis. 

• To create objects that are completely full of particles and do not have 
empty space inside: 

 
o Box or Cone:  Set the wall thickness to 0. 
o Pipe, Sphere, or Torus:  Set the inner radius to 0.  

 
With these basic shapes you can create a number of objects that are handy in 

particle analysis such as: 
 

• A box or pipe with openings can be used as a particle container, and a 

plate can be used to compress them. 

• A solid box might be used to represent ice in a liquid. 

• Torus segments can be used as a rounded pipe segments. 

• A frustum with open ends can represent a funnel.  The funnel can 

contain material that is injected into some other part of the system.  This 
case can be used, for example, to represent a 3D printer head, a medical 
device, or a portion of a die casting system. 

• Basic shapes can be combined with Boolean Operations to create more 
complex objects. 
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Revolved and Extruded Surfaces 

To create a body of revolution from a 2D surface, select Object➔Insert Object

➔Revolution.  The following dialog will be shown: 

 

 
 
Fill in the values: 

 

• Angle of Revolution.  The number of degrees to rotate the surface.  An 

angle of 0° is treated as 360°. 

• X-Y Coordinates.  Input the X-Y coordinate pairs for the surface, one per 

line, with values separated by a space or comma.  You need at least 
three pairs to create a surface.  An unclosed surface will result in a shell 
being created. 

• Axis of Revolution.  Select the axis around which to rotate the surface. 
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The above input will create a bowl: 

 

 
 
 

Creating an extruded object is nearly the same.  Select Object➔Insert Object➔

Extrusion.  A dialog similar to the Create Revolved Surface dialog will be shown 
(omitted here to save space).  The main difference is that you must input the 

extrusion length rather than an angle. 
  



46 – TenGun User Guide 
 

Part Colors 

To change the coloring of assembly parts, create a Discrete Colors table named 

“Assembly”.  The first part inserted uses the first color, the second part the 
second color, and so on.  If there are more parts than colors, TenGun cycles 

through the table from the beginning. 
 
The dialog for extrusion is quite similar and not shown here, except for extrusion 

you input the extrusion length instead of an angle. 
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Exporting Data 

 This section describes the two ways that TenGun can export data. 

 
Export Model as Point Cloud 

 This feature can convert solid 

models in the current scene to a point 
cloud. Any existing point cloud data in 

the scene is ignored during the conversion. 
 
Experimental Feature 

 
To create a point cloud of the model 

itself you only need to set the Point 
Size.  A point cloud is created where 
points fill all of the model’s surfaces. 

 
The “Use mesh scanner v2.5” option 

attempts to cover all surfaces with 
particles.  The legacy algorithm is 
similar, but it tries to identify solid 

walls, ignoring the empty space 
between those walls. 

 
The newer algorithm works better for 
objects that do not have explicit solid 

walls such as OBJ and STL meshes. 
 

 
The following settings allow you to create particle groups that can represent 
clumps of materials of different sizes: 

 

• Group Sizes.  This is a list of one or more cluster sizes separated by 

spaces or commas.  When set, the Point Size value becomes the 
minimum grid size, and each of the values in this list is the diameter of 
the cluster.  For example, if the Point Size is set to 100 (perhaps in 

microns), the Group Sizes might be 100, 120, and 140.  Values must be 
>= the Point Size. 

• Group Volume Distribution.  If Group Sizes is set, this field contains the 
desired volume distribution for each of the groups (e.g., 25, 50, 25) 

expressed as a percent of the total volume. Values are comma or space 
separated. 

• Create Single Particle from Group.  When unchecked, a “group” will 

consist of one or more particles of size “Point Size” organized as a 
sphere.  This organization is suitable for SPH analysis.  When checked, 

the group is output as a single sphere, which is more suitable for DEM 
analysis.   

Menu: File ➔ Export ➔ Model as Point Cloud. 
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• Random Number Seed.  Particle groups are placed randomly.  If you do 

not specify a Random Number Seed, the same input will generate the 
same output.  If you actually want to generate a different distribution, set 

this to a different seed.  Remember to make a note of your seed values 
so you can reproduce the same output if necessary. 

 

When generating particle groups, TenGun creates the Point Cloud file for the 
entire model, and one additional Point Cloud file for each Group Size.  The 

individual files can be imported back into an assembly, and then exported once 
again when creating Analysis Data. 
 

For simple objects, the default wall thickness settings are usually appropriate.  
Complex objects, however, may require some experimentation with these 

settings: 
 

• Minimum wall thickness.  When this value is non-zero, the algorithm will 

ignore short solid segments so that the segment will not be treated as the 
start of a wall.  While scanning a cylindrical object, for example, most of 

the time the scan detects going inside the cylinder, some empty space, 
and then the other side of the cylinder.  While scanning the extremes of 
the cylinder, however, the scan never actually goes inside.  Note that the 

units are points, so you may need to convert the wall thickness in your 
model (e.g., millimeters) to points to find a good value. 

• Maximum wall thickness. This is similar to the above, but instructs the 
scanner to discard false walls.  A false wall can occur if there are 

overhanging portions of the model such as flanges. 

• Scan Direction.  The scanning needs to find wall entrance and exit points 
in order to decide if there is empty interior space.  By default, the scanner 

does this in three dimensions.  In some cases, you can scan in only one 
direction to speed up the point cloud creation.  For complex objects, you 

can sometimes improve the output by scanning in only one or two 
directions.  (See examples below.) 

 

Output quality is also affected by the quality of the input. 
 

Finally, for interior point clouds you can set the Outside Spacing to shave off the 
specified number of particles in n the specified direction(s).  Use this option to 
prevent filling the object entirely.  For example, if you have a container of liquid, 

you may not want to fill it exactly to the top, so you with set the “Top” value to 
several particles.  This option is also useful in particle analysis to prevent 

particles from initially being too close to walls. 
 

Point Cloud Interior – Simple Example 
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This cup example works well with interior point creation.  

The cup is actually upright, but has been rotated so that 
you can see the inside. 

 
Scanning in the all three directions works with no 
problem.  Note, though, that the Y-direction scan does 

not detect anything because it only finds one wall.  
Therefore, the scan could actually be done only in the X 

or Z direction. 
 
Also, this is a perfect example of where “Outside Spacing” can be used.  Setting 

the “Top” value prevents the cup entirely to the brim. 

Point Cloud Interior – Complex Example 

This exhaust manifold is a nightmare: 
 

• We don’t want to include the holes in the 
flanges as interior space, but scanning 

horizontally this case looks like wall-empty-
wall. 

• Scanning vertically, the flanges look like the 

start of a wall, but we don’t want to treat them as walls. 

• We don’t want to treat the empty horizontal space between the upper 

pipes as interior space. 

• You can’t see it here, but the upper pipes are tapered.  They are thicker 

near the flanges than near the middle. 
 
The following steps allow you to create a reasonable (although not perfect) 

approximation of the interior: 
 

• Cut off the flanges with the 3D Cut function.  The flanges are probably 
irrelevant to the analysis anyway. 

• Scan only in the Y and Z directions.  This avoids a false wall problem 

between the pipes in the X direction. 
 

The result leaves some slight artifacts caused by the tapering of the pipes—a 
challenge left for a future version. 
  



50 – TenGun User Guide 
 

Export Analysis Data 

 This feature combines all of the objects on the current panel to create input 
data for a third-party analysis program.  When opening the files, pay careful 

attention to the "Load as separate parts" Open option as this will affect the 
number of generated parts. 
 

Operation is as then follows: 
 

• Apply part properties to each part in the scene: 
 

o Select an object.  If no part has been selected, the first part will be 

selected automatically. 
o Invoke the Edit Part Properties 

function.  The first you will be 
prompted for an “Export 
Template”. 

 
The template is specific to the analysis program you wish to use. 

The standard installation includes only a sample template 
“SampleApp.export” that you can use to learn how to use this 
feature.  Please contact us for information about templates that we 

have developed or about how to create your own template. 
  

Keys:   e   p  (“Edit Part” properties). 
 
Menu: 

    Object ➔ Edit Part Properties. 

    File ➔ Export Analysis Data. 
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o Set the appropriate property values.  

Again, this is specific to the target 
application, but typically includes settings 

for the material type, boundary condition, 
velocity, static load, and so on. 

o Experimental Feature.  You can use Edit 

Part Properties on faces and edges.  

Use Pick Faces ( p   f ), Pick Edges ( p   

e ), or Pick Vertices ( p   v ) to select a 

sub-object.  Then use Edit Part 
Properties to set the values.  This feature 
is useful, for example, to set a static load in a particular area of a 

part. 
 

• Select File ➔ Export ➔ Analysis Data.  In the 

dialog that is displayed, fill in the settings shown 

for the specific template: 
 

o General.  This includes general settings 
for the target application, and is where 
you set the desired particle size. 

o Header. Contains values appearing at 
the beginning of the generated data file. 

o Trailer. Contains values appearing at the 
end of the generated data. 

 

Part-specific data is written between the Header and Trailer sections.  
This data typically includes the coordinates of each particle, velocities, 

material type, boundary conditions, and other application -specific values. 
 

• Sometimes you have tables that are fairly constant such a table of 

Densities and Young's Modulus values.  In this case you can use the 
template processor’s "file" data type to insert these tables into your 

output. 

• When you select  OK , TenGun merges a point cloud for each input 

object (part) with your export template and part property settings into a 

single output file. 

• Optionally perform manual editing on the output file. This may be 
required if the template editor cannot automatically generate 100% of the 

output. 

• Run the analysis application. 

 

Hints 

• Your CAD model and particle size must use the same world coordinate 
dimensions.  For example, if you have a 10cm pipe and will have millimeter 
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particles, the pipe length should be 0.010 (meters), not 10 (centimeters).  If 

necessary you can rescale CAD objects using the Geometry Editor. 

• The most recent General, Header, and Trailer settings are saved in a file 

named “export_template_name.export.config”, located in the 
“C:\user_name\AppData\Roaming\TenGun” folder.   
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Assembly Example – Part 1:  Assemble the Parts 

This section is a step-by-step example of assembling various CAD parts, 
creating particle data to fill the inside, use of the Geometry Editor, and exporting 

the data for use in an analysis application. 
 

For this example, we will make a contraption for the person who has everything:  
a “Swiss Cheese Hole Filler”.  This is a totally useless device, but it is fun and 
easy to implement. 

 
Here is our strategy: 

 

• We want to make a device to push particles into this block of 
Swiss cheese.  The cheese data was a sample STEP file 

found on the Internet.  We know from inspecting the cheese 
in the Geometry Editor that the size is 50.8 x 50.8 x 50.8mm. 

• We need a container to hold the particles, so we’ll use TenGun ’s box 
object.  We also need a square plate that fits in the box.  The plate will be 
used to push the particles. 

• We need some particles to fill the box. 

• We’ll create the objects in this order:  Box, Plate, Particles, and finally 

cheese.  The reason for this sequence is that when we create the interior 
particles for the box, we don ’t want TenGun to pre-fill the cheese, too.  
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Create the Box 

Here we will use TenGun ’s built-in box object as a particle container.  As an 

alternative in a real world example, you can import your own CAD model as a 
substitute container. 

 

• Create a New Assembly scene (File ➔ New 

Assembly).  For this example you can use any 
Display Profile.  This selection only affects the 

colors that are used. 

• Create a Box (Object ➔ Insert Object ➔Box).  

Notice that the box size is set to the same size 
as the block of cheese.  (We want at least one 
dimension to be the same.)  Also notice that the 

“Front and Back” will be open.  One of the open 
sides will be connected to the cheese, and we will insert a plate in the 

other side. 

• The Scene Panel now shows the box like this. 

 
 
 

 
 

 
 
 

 

Create the Plate 

Create the plate with: 
 

• Object ➔ Insert Object ➔ Solid Plate 

• Set the dimensions of the plate to 42 x 42 x 4.  

42 is 50 –  the thickness of two walls. 

• Select  OK , and the Scene Panel will look like 

this.  (It is difficult to see here in 2D, but the 

black portion is a shadow, and the plate is 
inside the box.) 
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Align the Box and Plate 

We now have a box and a plate, but the plate is located at the center of the box.  

To align the plate to the outside of the box: 
 

• Type  p   f  (Pick Faces). 

• Click the plate.  It will be highlighted. 

• Click an outer edge of the box.  The front outer 

wall of the box will be highlighted. 

• Type  j  to join the objects.  The front face of 

the plate will be aligned with the front of the 

box. 

• The Scene Panel will now appear like this. If 

you rotate the scene to look from the back, 
though, you can see that the plate is indeed aligned with the front of the 
box. 

Create Cheese Particles 

To create particles to fill the box: 

 

• File ➔ Export Point Cloud. 

• Set the Point Size.  Remember this value 
because you will need it again later. 

• At this stage don ’t want to convert the box 
and the plate into particles.  Rather, we want 

to create particles to fill the inside of the box.  
Therefore, check “Create interior points”. 

• Select  OK . 

• Enter a file name to write the particles to.  
We’ve used “CheeseParticles.csv” here. 

• TenGun will create the particle data. 

Insert Cheese Particles 

Insert the particles into the box/plate assembly: 
 

• File ➔ Open. 

• Choose “CheeseParticles.csv”.  Be sure to 

check the “Append to current scene” option. 

• The scene, if rotated so you can see the back, 

will look like this. 
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Add the Cheese 

• File ➔ Open. 

• Choose “Cheese.step”.  Be sure to check the 

“Append to current scene” option. 

• The Screen Panel will appear like this.  As you 

can see, the Cheese object is on top of the 
box, which is not what we want.  We’ll fix this 
in the next step. 

 
 
 

Move the Cheese 

Use the Geometry Editor to move the cheese off of the box: 
 

• Make the Cheese object the active object. Since we have four objects in 

the scene, you can press “n” to go forward three objects (skip the box, 
plate, and particles) to the cheese, or you can press “N” to go backwards 

from the box to the cheese.  Going either way, you should end up with 
the cheese being be highlighted. 

• Press  Ctrl+G  or use Object ➔ Edit Geometry to open the Geometry 

Editor. 

• Recall that the box size is 50x50x50.  Move the Cheese object 50 units in 
the –Z direction using the Translate function so it is just outside of the 

box.  In other scenarios you may need to rotate something, or you may 
want to use Object Alignment to join faces. 

 

At this point the scene, rotated, should look like this: 
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Set the properties of each part as required by the analysis application.  One by 

one: 
 

• Select a part (right-click). 

• Invoke the Part Properties edit screen (type  e   p  or us the Object ➔ 

Edit Part Properties menu item).  We are not really going to run analysis 
in this tutorial, so you can pick any available Export Template. 

• Fill in the appropriate parameters.  In this example, each part must be 
given a unique value for the Material type, Bounds (boundary condition).  
Additionally, the VZ (Velocity-Z) value must be set for the moving plate. 

• Select  OK , and repeat for the other parts. 

 
In this example, the full assembly contains particles that are hidden inside the 

box, so you cannot right click them to select them.  In this situation you can 

select the part in the Tree View.  You can also type  n  or  N  to cycle through 

the parts until the selected object is not visible (because it is inside the box), 
and then invoke Edit Part Properties. 

 

Hints 

• It usually takes a few tries until the data is 
perfect.  As you add objects to the scene 

and move them around, use File ➔Save 

Assembly to save your work.  Then if you 

need to re-do something you can reload your previous data and modify it. 

• Notice that I have mentioned the rotated scene several times in this example.  

An alternative and perhaps better way of assembling the parts would be to 
attach the box to the right-hand side of the cheese instead of the front.  The 

box must then be initially rotated so the open front and back are oriented 
correctly, but that is perhaps easier. 

 

  

Menu:  File ➔ Save Assembly. 
 
This saves CAD objects only.  It does 
not save particle data. 
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Assembly Example – Part 2:  Create Analysis Data 

Next, we would like to run our cheese press contraption through an analysis 
program.  To do so: 

 

• Select File ➔ Export Analysis Data. 

• Fill in the parameters required by 
that application. 

• Select  OK . 

• TenGun converts the Box, Plate, 
and Cheese Block to particle form, 

and also include the “cheese 
particles” that we previously created. 

• Enter an output file name when 
prompted. TenGun will then write all 
of the particle data and analysis 

application parameters to that file. 

• In some cases you may want to 

perform some manual editing or 
fine-tuning on the output. 

• Run the analysis. 

  



 

TenGun User Guide – 59  

Object Editing Tools 

Operations shown with the Time Series Mode  icon operate only on data that 

originated as a Point Cloud.  Operations shown with the Assembly Mode  icon 
can be used with STEP and IGES data, and with STL data that was read with 

the extended reader. 

Analyze Mesh 

Display information about the various polygons types in a mesh. This provides 

useful information that can be used with mesh subdivision features.  Output is 
shown in the Message Window. 

Analyze Point Density 

Calculate the point density for the specified search radius.  TenGun then finds 
the number of neighbors for each point within that radius, storing the values in a 

field named “Neighbors”. 
 
Be careful to set the radius to no more than the particle size x 2 or 3.  Otherwise 

the search will include too many points and will take a long time. 
 

This feature is useful for spotting flaws in a model such as pores and cracks 
which will have low-density values. 
 

Background Mesh 

 Some time series data (e.g., from LIGGGHTS) consists only of particles 
without a container.  You can enhance to display by adding background meshes 
that represent the container and moving plates.  Property values of the mesh 

files are ignored. 
 

There are three options on the Background Mesh submenu: 
 

• Add.  If a single file is select it will be appended to any existing meshes in 

all scenes.  If multiple files are selected, each file’s mesh will be 
appended to the existing mesh for that scene. 

• Replace.  Same as above, but previously loaded meshes are replaced. 

• Remove.  Removes background meshes. 
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Points to Surface 

 This feature applies a Delaunay 2D or 3D to a point cloud, allowing you to 

create a mesh from a set of unstructured points.  
 
Usage is as follows: 

 

• Select the Tools ➔ Points to Surface menu item.  The following dialog 

will be displayed: 
 

 

 
 

• Fill in the parameters: 
 

o File name.  Enter the file name here, or browse by selecting the 

 …  button.  Supported output formats are OBJ, PLY, STL 

(default), VTK, and VTP. 
o Maximum Search Radius.  If set to zero, the filters output all 

triangles (2D case) or tetraheda (3D case).  If non-zero, output is 
limited to objects that fall within a bounding sphere defined by this 
radius.  In the latter case, vertices, lines, and triangles can be 

generated.  However, TenGun suppresses the output of vertices 
and lines. 

o Maximum Hole Size.  Holes in the mesh up to this radius are 
removed by a hole-removal filter. 

o Alignment.  If non-zero, particles are aligned so that the 

coordinates are all multiples of this value, and redundant points 
are removed. 

o 3D.  When checked apply a Delaunay 3D filter, othewwise a 
Delaunay 2D filter.  When you apply a 2D filter to 3D data, the 
filter ignores the Z-coordinate and creates a mesh of the surface.  

This is useful, for example, to create a lithophane. 
o Save as Text.  By default, output files are written in binary format.  

Check this option to create ASCII text files instead. 
o All Polygons.  By default, the generated mesh will consist of 

triangles.  If this option is checked and the output file type is either 

VTK or VTP, higher-order polygons such as tetrahedral will be 
written.  TenGun currently does not support displaying the 

resulting “unstructured grid” files.  However, you may use the 
output with other tools to extract the polygons. 
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• Select  OK  to start conversion. 

• The converted mesh may be saved in another format such as a STL, 

VTK, or VTP using the File ➔ Save Point Data menu item.  This data can 

then be used as input to another process, and even used for 3D Printing. 
 

Notes 

• For 3D, the tool is currently limited to moderately-sized input data up to a 

few hundred thousand points because the conversion process can become 
slow and use a lot of memory. 

• For 3D, you will generally get good results if the Maximum Search Radius 
setting is approximately 2 to 3 times the point spacing.  If you use a larger 
value, distant corners of the object can be connected, and you can end up 

with a useless giant blob. 

• The Delaunay algorithm is likely to fill in small holes.  To preserve the holes 

you must provide particle input data with finer spacing. 

• The Delaunay algorithms work best with irregularly shaped objects.  For 

example, conversion of simple plates or cubes is very slow. 

• Very thin areas do not convert well with Delaunay 3D.  Thin areas need to 
be a few particles thick.  Otherwise these areas are likely to become holes.  

A trick that works in some cases is to rotate the object slightly so that the flat 
portions are perfectly parallel to a major plane. 

• During conversion from a point cloud to a mesh, scalar values such as 
temperature and pressure are lost. 

 

Remove Outliers 
 This feature removes “rogue particles”, that is particles that have leaked from 

the simulation container.  Such particles can interfere with the display because 

particles at extreme positions require that the camera be very distant in order to 
view the entire model. 
 

When this feature is selected you will be prompted for the Minimum Neighbors 
and Search Radius (a multiple of the particle size).  Any particle that does not 

have at least “Minimum Neighbors” particles within this radius are removed. 
 
The Remove Outliers function cannot be undo (you need to reload the data to 

get back the original). 
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Subdivide Triangles 

 This feature first converts non-triangles to triangles.  Then, all triangles are 

subdivided according to the specified criteria, resulting in a triangular mesh with 
more detail than the original. 
 

Usage is as follows: 
 

• Prepare a mesh.  You can read this from a CAD file, or create a mesh via 

the Tools ➔Subdivide Triangles menu item.  The following dialog is 

displayed: 
 

 
 

• Fill in the parameters: 

 
o Maximum Edge Length.  Edges that are longer than this value will 

be divided in half, and associated triangles regenerated. 

o Maximum Triangle Area.  Triangles with an area larger than this 
value will be subdivided.  This option may sometimes introduce 

holes into the mesh. 
o Maximum Number of Iterations.  The subdivision process is 

iterative.  You may limit the number of passes by setting this value. 

o Maximum Number of Triangles.  You may limit the number of 
triangles generated.  However, if the limit is reached, the result 

mesh may contain holes. 

o Select  OK  to start conversion. 

 

Object Alignment 
 When objects are inserted or loaded from a file, you may need to align them 

before generating analysis input data.  There are two ways to align objects.  

The first is to use the “Join Faces” function, and the second is to use the 
Boolean “Union” operation. 

 
There is a very subtle but important difference between when using “Join Faces” 
versus “Union”.  A union creates a single part, whereas “Join Faces” leaves the 
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original parts, but they are very close together.  Separate objects can be 

assigned different materials and boundary conditions for an analysis application. 

 

Join Faces Operation 
 To join two objects using two faces: 

 

• Activate Face Picking Mode ( p   f  from the keyboard). 

• Click on the face of the first object to be aligned. This will be the "from" 
object. 

• Click on the “to” face that you wish to align with the “from” face. 

• Press  j  or  J  ("Join").  The “j” case joins using the minimum angle 

between the faces, and “J” uses the maximum angle.  The latter case 

can be used when you want to flip the object over. 

• You will be prompted for the “Object Spacing”, which in this case is the 

spacing between the faces.  If this is set to 0.0 the faces will be aligned 
exactly.  However, you may want to set this to the particle size that you 
will use later so that generated particles are not too close. 

• Select  OK .  The "from" face" will be rotated and moved so that it aligns 

with the "to" face. 

• Undo a Join by typing  Ctrl+Z  or from the Edit ➔ Undo menu item. 

 

Objects are aligned using normal vectors to the selected faces. There are two 
normal vectors to any face pointing in opposite directions.  The meaning of 
“maximum angle” and minimum angle is ambiguous when rotating 90° or 180°, 

so you may have to try both “j” and “J” to see which works for the particle case. 
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Boolean Operations 

 The following Boolean operations may be performed from the Tools menu: 

 

• Difference.  The first object selected becomes a “cutter”.  The 

intersecting areas of the cutter and each of the other selected objects is 
removed, and then the cutter is deleted.  This operation is useful, for 
example, to create holes in other objects. 

• Difference (cut only).  Same as above, but the cutter is not deleted. 

• Intersection.  Create an object containing the common portion all 

selected objects.  The most recently selected object is replaced. 

• Union.  Create a single object from all selected objects.  The most 

recently selected object is replaced.  See also Join Faces. 
 
 

Difference and Intersect operations may be applied to STEP and IGES data, 
and Union may be used with any type of data. 

Boolean Operation Example 

In the following example we wanted create two plates which in the analysis 

program will consist of different materials.  Additionally, a hole is required 
through the plates.  This data can be created as follows: 
 

• Create two plates.  Shift one plate with the Geometry Editor so that it 
doesn ’t overlap the other plate. 

• Create a pipe with the inner radius set to zero. 

• Select the pipe. The first object selected becomes the cutting tool. 

• With the  Shift  key pressed, select both plates in either order. 

• Use the Boolean ➔ Difference operator to cut the pipe out of both plates.  

The pipe is deleted by the Difference operator.  
 
 

   
 
Using the Difference operator on multiple objects is handy in this case—

otherwise you would need to insert and the cutter multiple times. 
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Advanced Cut Operations 

The Difference Boolean Operation can often be used to make simple cuts, but 
more complex cuts may require several steps.  One particular case is described 

here. 
 

Suppose you have a CAD object such as an engine block from which you want 
to create a die casting mold.  Therefore, you need the engine block, a box to 
represent the mold, and a pipe going through the mold into which you will inject 

liquid metal.  You can easily join a pipe to the engine block and then add a box, 
and you can then use the Difference operator so that the pipe will cut through 

the box. 
 
However, the Difference operation deletes the cutting tool (the pipe), and once 

you have added the box it is difficult add back a replacement pipe with the same 
alignment.  The solution to this is: 

 

• Instead of Difference, use Difference (cut only).  This breaks up the CAD 
object into three parts:  the mold minus the exterior of the pipe, the 

exterior of the pipe, and finally a disk representing the interior of the pipe 
(which we do not want).  

• Select the mold, and apply the Tools ➔ Split Compound operation.  This 

splits the mold into two pieces: the remainder of the mold (minus the 

exterior of the pipe) and the disk. 

• Select the disk and delete it. 
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Create Hollow Solid 

 Some CAD objects such as in STEP files are represented only by boundary 

representation.  If you try to export this as a Point Cloud you will end up with a 
solid block of particles.  This is because the visible walls in the model actually 
have no thickness, so the conversion process thinks that the entire object is a 

single wall.  However, in most cases you want the inside to be hollow, which 
you can achieve as follows: 

 

• Select one of the major faces, such as the frontmost face (type   pf  to 

enable face picking, and then click the face.) 

• Select the Tools ➔ Create Hollow Solid menu item to display the Create 

Hollow Solid dialog. 

• Fill in the “Wall Thickness” value.  The units are the same as in the object 
unit. 

• Select  OK , and each face is “thickened” in the inward direction. 

 
Now you can export the object as a Point Cloud with hollow insides. 

 

Repair Shape 

 The Tools ➔ Repair Shape menu item performs basic repairs to objects 

such as connecting disconnected edges and combining edges that are very 
close together into a single edge. 
 

You will be prompted for: 
 

• Precision.  The general precision limit used by the repair tool. 

• Maximum Tolerance.  The limit to use when determining if the objects 

such as edges are “close”. 

• Minimum Tolerance.  The limit to use when determining when objects 
such as vertices are close enough such that they can be combined. 

 

Subdivide Faces 

 The Tools ➔ Subdivide Faces menu item splits all faces such that no face 

has an area larger than the specified size. 

 
You will be prompted for the desired maximum area. 

 

Subdivide Surfaces 

 The Tools ➔ Subdivide Surfaces menu item splits surfaces with extreme 

angles into multiple surfaces having the specified maximum angle. 
 

You will be prompted for the maximum desired angle. 
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Edit Geometry 

 When you move or rotate objects with the 

mouse, you are actually moving the camera.  
However, when you are combining objects to be 
used for analysis, you may sometimes need to 

edit the underlying geometry itself using the Geometry Editor.  Operation is as 
follows: 

 

• Select the object to be edited with a right-

click.  You make also type  n  (next) or  N  

(previous) to cycle through and select 

objects. 

• Open the Geometry Editor by pressing   

Ctrl+G  or from the Tools ➔ Edit 

Geometry menu item. 

• Use the dialog settings to perform the 
desired operation(s): 

 
o Center the object at (0, 0, 0). 
o Scale (resize) the object. 

o Rotate the object.  Rotation is 
counterclockwise at the angle specified in degrees.  If “Use Local 

Origin” is checked, rotation is around the center of the selected 
object, and if unchecked rotation is around the scene. 

o Translate (move) the object. 

 
Click the corresponding button to apply the transformation . 

• Select  OK  to make apply the changes to the in-memory working data.  

The original on-disk copy is not modified unless you resave the object to 
a file. 

• Undo a geometry edit sequence by typing  Ctrl+Z  or from the Edit ➔ 

Undo menu item. 

 
The Geometry Editor is intended for use with CAD data formats such as STEP 
and IGES.  You may also edit Point Cloud data with this editor, although we are 

not sure if this is actually useful. 

Hints 

• To reset viewpoint after making extreme modifications, use Zoom In, Zoom 

Out, and the Camera menu and its shortcuts such as  Ctrl+F  (“View from 

front”). 

• TenGun tries to avoid excessive redrawing while you’re editing the geometry.  
However, if the object goes out of view you can click the  Redraw button to 
readjust the camera. 

Keys: Ctrl+G: Edit Geometry. 
 

Menu: Object ➔ Edit Geometry. 
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• The modified geometry’s new position and orientation become the new 

values used by the  (“Home)” button.   
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Image Display 

TenGun can display BMP, JPEG (JPG), PNG, and some TIFF image files. This 

feature is provided mainly as a convenience so that you do not need to start a 
separate application to view images. 

 
TenGun can also display DICOM (Digital Imaging and Communications in 
Medicine) images.  Please note the following: 

 

• DICOM files must have an extension of “.dcm”.  Sometimes these files 

have no extension, and we are therefore expected to read the 
DICOMDIR directory file.  However, we do not currently read this file at 

this time although may add this capability in the future as we collect more 
data. 

• The “Next” and “Previous” keyboard commands will scroll through a 

series of DICOM images or through a multislice DICOM series. 
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Text Editor 

TenGun includes a full-featured text editor.  This is based on the popular 

“Scintilla” editor plugin from www.scintilla.org. 
 

This editor is primarily a source code editor, and it therefore contains a number 
of features such as syntax highlighting.  At the moment, these programmer-
friendly features are not accessible from within TenGun, but we may enable 

them in the future. 
 

With the extra source code handling features and internal storage of text as 
Unicode, the editor tends to be a bit memory-intensive.  Therefore, you should 
not try to edit huge data files with this editor if you have a limited amount of 

memory.  Additionally, even if you have a lot of memory, the maximum file size 
is currently 2GB. 

 
This document does not discuss editor operation in detail.  Please refer to the 

“TenGun Quick Reference” (available from the Help ➔ Quick Reference menu 

item) for a table of keyboard commands. 

 
 
 

  

https://www.scintilla.org/
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Performance Hints 

Performance on large datasets using the graphics capability built-in to the CPU 

is horrible. Therefore, if you have a GPU device you definitely want to set this 
as the preferred graphics device for this application. 

 
For NVIDIA on Windows: 
 

• Right-click on a blank area on the Desktop and select "NVIDIA Control 
Panel". 

• Under "Manage 3D Settings" select "Program Settings". 

• Use the Add function to add an entry for TenGun.exe. (Browse to where 

TenGun is installed to find the exe file.) 

• Click "Apply" to activate the new preference. 

• Close the NVIDA Control Panel. 
 

Experimental Features 

Certain features in TenGun are marked as “experimental”.  These are features 

that may not work perfectly either because something is beyond our control, or 
because the feature itself is borderline impossible.  Therefore, features marked 
as “experimental” are excluded from our standard warranty.  Included in this list 

are: 
 

• The file browser.  The basis of this feature is within a library that we use.  
It is known to sometimes fail with a yet-to-be determined complex 
sequence of mouse events.  The same code also has difficulty dealing 

properly with removable drives, and has slow response when a slow 
network connection is involved in the view.  The file browser is very 

handy when it works, but please keep these limitations in mind. 

• Point Cloud Export, Interior Points.  This feature does not work for all 

geometries, as discussed in this document. 

• LS-DYNA support.  We have only a limited number of LS-DYNA files, 
and we know that some cases do not work.  So that we may remove the 

“experimental” status, any files that you can share with us would be 
greatly appreciated. 

 
 
 


