
TenGun™ Update History 
 
This document describes major changes to TenGun.  See also Known Issues 
and Limitations at the end of this document. 

Version 2.5.0.2 
October 24, 2023 
 

• Improved Remove Outliers, and fixed an issue where it could crash if “all 
scenes” was disabled. 

 

Version 2.5.0.1 
October 8, 2023 
 

• Some code was added to default using the first object if nothing has 
been selected.  At the moment, however, this code is effectively disabled 
by the UI filters.  The filters may possibly be relaxed in the future. 

• Introduced a new algorithm for creating exterior point clouds.  The new 
algorithm can deal with meshes that do not have explicit walls including 
some OBJ and STL files.  A related modification to handle the interior 
case is forthcoming. 

• There is a new popup dialog that appears when you use Cut Volume or 
Cut Plane.  This allows you to manually specify cutting coordinates, as 
well as using the original cutting “handlies” with the mouse. 

• The Distance Measure only displays the distance after both handles 
have been placed.  This prevents the measurement widget from 
displaying a misleading intermediate value. 

• The profile now has a “Name Filter”.  This is a C++11 basic regular 
expression that can be used to extract a portion of a complex file name 
to be used as the tree view label.  Assembly Mode only. 

• The Open File Options dialog has a new field “Group Name”.  When 
opening multiple Assembly Mode files, the Group Name can be assigned 
to each file.  The new Object → Select by Group Name feature may then 
be used to easily select all of the objects with the same Group Name 
value.  Assembly Mode only. 

• The Object → Set Object Color feature may be used to apply a custom 
color to the selected object(s) rather than the automatically assigned 
color.  Assembly Mode only. 

• The following features now work with the filtered data: “create points from 
image”, “points to surface” (2D and 3D).  Export points to data already 
did this. 



• You were previously not allowed to load multiple 3D CAD files at once in 
Assembly Mode.  This is now allowed, but please be sure you are in the 
correct Mode (Assembly or Time Series) before you do this. 

• In Assembly Mode, pressing “s” toggle the selection of all objects.  This 
can be helpful for doing a Boolean Union of a large number of parts. 

• You are now allowed to expert a scene as .obj files. 

• There is now an “extended” reader for .obj files, which will create OCCT-
compatible objects. 

 

Version 2.5.0.0 
Last updated August 25,2023 
 
Added support for DICOM medical images as a standard feature.  Please note 
the following: 
 

• DICOM files must have an extension of “.dcm”.  Sometimes DICOM files 
have no extension, and we are expected to read the DICOMDIR 
directory file.  However, we do not currently read this file at this time 
although may add this capability in the future as we collect more data. 

• The “Next” and “Previous” keyboard commands will scroll through a 
series of DICOM images or through a multislice DICOM series. 

 

Version 2.4.0.8 
Last updated July 10, 2023 
 

• “Remove Outliers” was crashing. 

• Rebuilt VTK 9.1 library to include the vtk-dicom and GDCM libraries. 
Source for both in is TenGun-ThirdParty, and GDCM is installed in 
C:\GDCM.  

Version 2.4.0.7 
Last updated May 16, 2023 
 

• Added back “SetFocalPoint” to LookAtFace because an initial time series 
display was not really looking at the front since 2.4.0.6. 

Version 2.4.0.6 
Last updated March 6, 2023 
 

• Improved automatic camera positioning to avoid shadows when you you 
made extreme changes to an assembly such as moving a large pipe. 

• Fixed: After deleting an Assembly Mode object, the screen was not 
refreshed until you moved the mouse. 



Version 2.4.0.5 
Last updated February 21, 2023 
 

• Fixed: Pick Points was displaying unsigned integer values including 
generated point IDs as floating point. 

Version 2.4.0.4 
Last updated February 20, 2023 
 

• Version 2.4.0.4.  Fixed problem introduced at 2.4.0.3 affecting most Time 
Series editing. 

• Version 2.4.0.3. Fixed problem where Pick Face would show a selected face 
but in the wrong position.  The sequence to cause this was Edit Geometry or 
Join, Pick Face, Undo Edit Geometry, Pick Face.  In this case the shown 
face would be at the location before the undo.  

Version 2.4.0.2 
Last udpated July 28, 2022 
 

• You may have a file located in C:\ProgramData\TenGun\ProfileMap.dat that 
can be used to automatically select profiles based on matching the file name 
with a regular expression. 

 

Version 2.4.0.1 
Last updated November 17, 2022 
 

• A change to VTK 9.0.1 caused point cloud generation to fail if you had 
transformed the object just prior to creating the point cloud.  A temporary 
workaround is to save the model and reload it before point cloud generation. 

 

Version 2.4.0.0  
Last updated July 20, 2022 
 

• Changed development environment from Visual Studio 2015 to Visual 
Studio 2019. 

• Object -> Insert Pipe can now also create a 2D circle. 

• Implements “Pick Vertex”.  Additionally, you may now set part properties for 
a vertex. 

• Moved three export-related functions to a new File →Export submenu, and 
changed the menu label slightly.  With these menu items in one place, 
usage is a bit clearer. 

• The action keys for View Solid and View Spheres are now “vs” and “vh” 
respectively. 

• Allow creating of interior particles in multiple sizes.  There are two variations.  
The first creates different sized particles and is suitable for use with DEM 



analysis.  The second method creates particle clusters of multiple sizes for 
use with hybrid SPH analysis. 

• The csv reader could hang with some input file formats if the input did not 
match the profile settings. 

• Documentation display may fail if you have recently installed or updated 
Microsoft Edge.  Normally we assume that you will be using Adobe Acrobat 
Reader.  However, when Edge is installed, it might change the default PDF 
reader.  To fix this, use the system File Explorer application to navigate to a 
folder with any .pdf file.  Right click on a .pdf file and select “Open with → 
Choose other”, and select Acrobat Reader as the program to run.  You 
should also check the “Always use this choice” option. 

• New menu options:  Changed “File → Open” to “File → Open data file”, and 
added “File → Open text file”.  The latter option opens the text editor, and 
you may no longer open the editor via the “data open path”. 

• Movie creation was moved from an internal implementation to the command 
file C:/ProgramData/TenGun/CreateMovie.cmd, which you may customize.  
This change allows you to create mp4 files, which are otherwise restricted 
by mp4 licensing restrictions, and you can also customize other attributes of 
the movie.  However, you must now separately install a movie creation tool 
such as the free FFmpeg, and you will probably need to edit 
CreateMovie.cmd to find ffmpeg.exe (or whatever other tool you choose). 

• The keyboard command “pc” clears the point history. 

• The “Cut Plane” functionality was been modified to now update the display in 
real time as you move the cutting plane.  This way you can see a preview of 
the final object before you finalize the cut. 

• Fixed problem where Setup dialog might contain the wrong settings when 
you switched tabs and the tabs used different profiles. 

• You can toggle lighting effects by pressing “l” (letter “l”, for “light”), or via the 
View menu.  The default is “on” (same as before). 

• The “Add Offsets” feature has been replaced with a “Make Solid” feature.  
This converts planes into thick walls such as you might find in STEP data, 
and is handy when converting a CAD model to particles. 

• To select an interior face using Pick Face, type a number “1” through “9” 
(“n”) before clicking.  This selects the nth face behind the clicked face. 

• The “2D Plate” feature stopped working because of internal changes in VTK. 
This is under investigate, but until it is fixed, please do not use this feature.  
If you need such an object perhaps you can just work with a very thin 3D 
plate. 

• Fixed bug in TrimQuotes where excess quotes would be removed. 

• If you set the filename extension for a movie to “.all”, TenGun will create 
movies in all supported formats.  The actually extensions generated will 
be .avi, .mp4, and .ogg. 

• Keyboards commands “x”, “X”, “y”, and “Y” will rotate the camera 10 degrees 
about the x or y axis.  “x” and “y” rotate counterclockwise, and “X” and “Y” 
clockwise. 

https://ffmpeg.org/download.html


• Added “Animation Showcase Mode”.  At the end of an animatation, 
automatically rotate the scene so you can showcase the final product. 

• Huge performance increases for assembly mode object picking. 

• When reading text data, you can now specify to “read only every nth value”.  
This is a speedup and also saves memory; it is very handy if you need to 
read lots of huge data files for an animation, especially when you have a 
limited amount of memory. 

• Fix a problem in LookAtFace where if you had extreme object bounds such 
as after scaling, the entire scene might not have been visible. 

• Display an image (jpg, png, bmp, and some tiff files).  You can also create a 
lithophane from an image file (experimental, and none of this is documented 
yet). 

• Removed “Beta” designation 2022-07-20.  
 

Version 2.3.0.0 
 

• Implements “Pick Vertex”.  Additionally, you may now set part properties for 
edges and vertices as well as for faces. 

• Implements an alternate “STL” file reader.  The default reader is fast.  The 
new, alternate reader is slower, but the data can be used with advanced 
features such as Boolean operations. 

• Full-featured text editor. 

• Convert Point Cloud to Surface function.  Additionally, Point Data may now 
be saved as an STL, VTK, or VTP file as well as a DAT or CSV file. 

• Triangle Subdivision filter. 

• The Export Analysis feature now remembers the most recent General, 
Header, and Trailer settings. 

• You may now create a “Wedge” object in Assembly Mode. 

• You may now explore many Assembly Mode features without having a 
“Professional” license.  However, in this case you may not save related files. 

• A Point Cloud may now be exported in Wavefront “.obj” format.  This format 
can be used by some 3D Printers. 

• Added Tools → Add Background Mesh.  Allows you to add a mesh to 
enhance the display of particle-only data. 

• Added Tools → Add Offsets.  This feature adds a small offset to all faces, 
and helps eliminated conversion to point cloud format for objects that have 
boundaries but not walls. 

• Added Tools → Analyze Mesh to display a mesh’s polygon information.  
Useful when you need to subdivide a mesh. 

• Added Tools → Analyze Point Density.  This calculates the number of points 
within the specified radius, and can useful for finding pores and cracks. 

• The “SimpleXYZ.profile” has been replaced by the “XYZ.profile”.  This no 
longer contain an “ID” field.  Also, creating point cloud data no longer writes 
an ID field. 

• Create Objects of Revolution and Extruded Objects. 



• Added rotation around local origin in the Geometry Editor. 

• Create Solid Plate or Solid Disk of depth=0.  This creates a 2D object, which 
can be used in some DEM applications. 

• Added Object → Duplicate to create duplicates of objects. 

• Coordinate positions read from text files were previously always set to type 
“float”.  This can now be either “float” or “double” as per the profile setting. 

• In addition to the step number and other fields, display the elapsed 
simulated time in an animation. 

• You can now display a static background image in a Time Series view. 

• A Discrete Color Table may now be used with floating point data types. 

• Movies may now be saved in “ogg” format.  This format is compatible with 
the HTML5 <video> tag.  Later it was discovered that this mostly only works 
with desktop browsers, so we will be adding additional formats in the future. 

• Problems with the File Browser now seem to have been largely tamed. 

• Reintroduced the “measurement” tool for measuring between points. 

• A number of dialogs such as for creating a solid plate would not allow you to 
enter a tiny value such as 1um thickness.  Changed internal precision 
parameter from 5 to 9. 

• Updated chart code so Filters now work after having moved scalars from cell 
to point data.  Version 2.3.0.2. 

• Enhancements to Export Analysis Data allow you to split the output into 
separate subsections similar to style used by LIGGGHTS and OpenFOAM.  
Version 2.3.0.2. 

• Changed “Load as separate part” option to “Load as single part”.  Version 
2.3.0.3. 

• Added Ctrl+S shortcut to save a text editor file. Version 2.3.0.3. 

• Add some more details to Analyze Mesh for CAD objects, and added two 
missing Japanese translations.  Version 2.3.0.4. 

• Added “sa” command.  This toggles the use of the aggregate scalar bar 
range values during animation.  The default is “on”.  When “off”, each 
animation scene uses its own minimum and maximum values.  Version 
2.3.0.5. 

• You could get a reported exception reading some STEP or IGES files the 
number of potential roots differed from the number of transferrable roots.  
Fixed in Version 2.3.0.5. 

• Minor extensions to the “Repair” feature.  Version 2.3.0.5. 

• Allow “Points to Surface” in Assembly Mode.  Experimental.  Version 2.3.0.5. 

• Added some support for a string data type.  You must explicitly define this 
type in profile.  At the moment, the only place where string values is in the 
Pick Points attribute display.  Version 2.3.0.6. 

• Fixed problem if you were switching between a picking mode and 
measurement mode.  Version 2.3.0.7. 

• Fixed problem in exporting point cloud of a cylinder with caps where there 
was empty space around the front cap.  Version 2.3.0.7. 

• Changed how “expired license” messages are displayed.  Version 2.3.0.8. 
 



 

Version 2.2.0.x 
 

• Set the Scalar Bar range to specific values (Set “Scalar Bar Max” and Scalar 
Bar Min”) in the Field settings.  To use the actual range, reset both values to 
0.  Version 2.2.0.14. 

• Recreate the point picker between Time Series steps so that the picker’s 
internal cache feature won’t pick old data.  Also change the picker tolerance 
from 0.025 to 0.005 so that the picking ray is less likely to pick a point on the 
side of the desired point.  Version 2.2.0.13. 

• Point Picking after displaying an animation would restart animation.  Version 
2.2.0.12. 

• The filter expression setting was lost when switching between tabs.  Version 
2.2.0.12. 

• Reading some files (including STEP files) recently became slow for no 
obvious reason.  Rebuilt with the latest VTK and OCCT libraries, and the 
problem seems to be fixed.  You must reinstall to get these rebuilt libraries.  
Version 2.2.0.11. 

• Possible workaround for the infamous File Browser problem.  Version 
2.2.0.10. 

• Speedup for “Export Analysis Data” by limiting avoiding some 
Unicode/ASCII conversions.  Version 2.2.0.9. 

• Export Analysis Data could fail while exporting edge data (off-by-one loop 
limit error).  Fixed in 2.2.0.8. 

• The VTK readers now handles most variations, not just “Polydata”. Version 
2.2.0.7. 

• Chart legends can now display kanji characters.  Version 2.2.0.6. 

• Color table and field names may now contain “_”.  Version 2.2.0.5 

• The Report feature wasn’t changing fields.  Fixed in 2.2.0.5. 

• Distribution Chart:  Check if field range is 0.  Fixed in 2.2.0.5 

• After closing a chart, Time Series colors in a different tab were incorrect until 
you changed a filter or field selection.  Fixed in 2.2.0.5. 

• Treat VTK files as a solid model or point data depending on if there are any 
polygons or not instead of based on whether the file contains an 
unstructured grid.  Version 2.2.0.4. 

• A confusing “Debug Alert” message was displayed if you have not installed a 
PDF file reader.  (A PDF reader is required to display the documentation and 
help files.)  Fixed at 2.2.0.3. 

• Force filename extension to “.csv” before exporting point cloud.  Otherwise, 
if the input has one of our “CAD” extensions, the content is saved as csv, but 
the name has a CAD extension.  Fixed in Version 2.2.0.2. 

• “Save Point Data” wasn’t working sometimes due to a recent internal change 
in handing filtered versus unfiltered data.  Fixed in Version 2.2.0.2. 

• Optionally add caps to the end of a pipe.  Version 2.2.0.1. 

• Point picking could sometimes fail.  Fixed in Version 2.2.0.1. 



• Major internal modification to object picking.  You can now deselect a 
selected object when using multi-selection.  This is a prelude to being able 
to move assembly objects individually with the mouse. 

• Major enhancements to Export Analysis Data: 
o You now set part properties by selecting a part, and then using the 

“Edit Part” command to display the properties dialog.  This should be 
repeated for each part in a scene.  (Previously you set the properties 
for all parts at one time in one large dialog when you exported the 
data.) 

o You can now set the properties for individual faces.  This allows you 
to set boundary conditions such as a static load on just a face instead 
of an entire part. 

• If you open multiple Time Series views and show them side-by-side, you can 
scroll them forward and backwards in parallel. This behavior is enabled by 
clicking the “Arrow + Lock” button on the Toolbar. 

• All chart types now resize when window is resized.  Also, charts now apply 
the active filter.  (The latter may have worked at one point, and then broken 
during 2.2 development; did not confirm.) 

• New “Timeline” chart type.  Used for showing average, maximum, minimum, 
and standard deviation on variables in Time Series data. 

• Temporary images for animation were previously stored in a folder named 
“TenGun_Animation”.  This data is now stored in a unique, per-scene folder, 
so you may run multiple instances of TenGun without interference. 

• Revisions to face and edge picking. Fixes problem with face picking with 
IGES objects. 

• The Union and Difference Boolean Operations can now be applied to 
multiple objects. 

• Volume Cutting is now applied to all sub-scenes in a Time Series. 

• In addition to Points, Spheres, Solid, and Wireframe display mode, there is 
now a Vector mode for Time Series views.  A vector is defined in the 
General Settings as a set of fields, two for 2D or three for 3D data.  The 
vector is displayed from each point in the model in the direction of that 
vector.  The length is normalized over all such vectors, and can be multiplied 
by a scale factor, and the vector color is determined by the coloring of the 
currently selected field. 

• The Reset View function is now defined to be:  Undo all edits, reset zoom 
level, and reset the camera to the front view. 

• Upgraded to wxWidgets 3.1.1.  This does not fix the problem with the File 
Browser, so the File Browser is disabled by default, and you should use it 
only at your own risk. 

• Always show all defined scalar bar colors for discrete values instead of 
trying to hide unused colors.  That is too tricky and didn’t work perfectly. 

• The workflow for exporting analysis application data has changed. Please 
refer to the User Guide for details. 



• Object Repair features. Fixes inconsistent edges and vertices, split surfaces 
with large angles into smaller surfaces, and split large faces into smaller 
faces. 

• Fixed:  Make the selected profile the active profile even if a file couldn’t be 
loaded.  For example, a new version of some output might have tiny 
differences in the number of fields which might cause the load to fail.  If we 
don’t remember the profile at that point, you would annoyingly have to keep 
reselecting it.  Also in 2.1.0.7 

• Fixed:  Point Picking report was incorrect when you have cut the model (we 
need to search the uncut data, not the currently cut data for the picked point).  
Also fixed in 2.1.0.3. 

• Fixed:  Program would fail if trying to display a Histogram with kanji 
characters.  Also fixed in 2.1.0.3. 

• Fixed:  A timing issue could cause a hang, mostly noticeable if you loaded a 
series of small files. 

• Fixed:  Suppress error message about non-existent registry key 
“FontMapperFamilyFallback”.  Also fixed in 2.1.0.4. 

• Fixed:  Model could be displayed in mixed solid and wireframe mode. 

• The STL file reader that we switched to recently has horrible performance, 
so we switched back to the previous version.  Also changed in 2.1.0.5.  
However, with this change you can no longer perform some advanced 
editing operations on STL objects such as Difference, Intersect, and Repair. 

Version 2.1.0.9 
 
• Export as X3D (successor of VRML).  There is no import function. 

• The File Browser is still funky in some cases.  May assert with certain yet-to-
be-determined mouse interaction.  Please use at your own risk until a 
solution is found. 

• Color mapping could be lost during filtering.  2.1.0.6. 

• Always make the requested profile the current profile.  See discussion for 
2.2.0.0 above. 

• For Cut Plane from the Toolbar you can now initially start in the opposite 
direction (Left Cut becomes Right Cut, etc.) by pressing the shift key. 2.1.0.8.  
Also, status bar help doesn’t appear for toolbar buttons, so extended the 
tooltip for the cut buttons to show that “pressing ‘I’ inverts the cut direction”. 

• Fixed:  Difficulty getting kanji fonts to display on Windows 7 due to changes 
in how font mapping works.  2.1.0.9. 

• Eliminated dependency on a Visual C++ 2010 library in freefont.dll. 
  
 

Version 2.1.0.0 
 
• Internal File Browser. 



• Use only “Shading” mode for OCCT objects.  Wireframe mode could show 
simplified mathematical models (e.g., a sphere would be two circles), which 
can be confusing for our purpose. 

Version 2.0.0.5 
 

• Different Menu Bars for Time Series and Assembly Modes. 

• IGES:  Read files with multiple parts, the same as with STEP support. 

• Create a solid sphere by setting inner radius to 0. 

• Save Assembly:  Add IGES and STL support to Save Assembly.  The output 
format is decided by the file extension, and the default is “.step”. 

• Force view to solid mode while exporting point clouds.  Otherwise we would 
turn a wireframe into particles. 

• Save selected point data in a text file.  Useful if you want to take a subset of 
data and use it in a spreadsheet or other application. 

• Don’t automatically reset camera in the Geometry Editor.  (Automatic reset 
could be annoying.)  Use the Camera options to reset manually as desired. 

• Simplification to the Join operation, and modified explanation as to how it 
works. 

• Torus object. 

• When an object is inserted, select it automatically. 

• 3D (“Volume”) Cut. 

• Undo 2D Cut, 3D Cut, Delete, Boolean operations, and Edit Geometry 
operations. 

• Charts:  custom multi-line titles. 

• Charts are now displayed in the tabbed panels instead of an independent 
window. 

• Built-in File Browser.  You can directly Drag & Drop files from the browser 
into a scene without going through a “regular” file open dialog.  

Version 2.0.0.4 
 
• Initial support for 2D data handling.  Read STEP, IGES, .csv, and .dat 2D 

files.  Create 2D point clouds.  Additional modifications will probably be 
required. 

• Read .csv files that do not have a header.  In this case we fall back to “.dat” 
mode. 

• License information in the About box was not refreshed after installing a 
license. 

• Assembly colors were based on the default Discrete Color table, but that 
table is annoyingly reset each time you run TenGun.  There is now an 
internal Assembly Color Table, and this can be overridden by a user-defined 
color table named “Assembly”. 

• You can now create a solid cylinder by creating a “pipe” and setting the inner 
radius to 0. 



• It is too easy to accidentally open a series files in Assembly Mode when you 
intended to open a Time Series.  (The results are very colorful, but probably 
not what you intended.)  Therefore, if you select multiple files in Assembly 
Mode, only the first will be opened and a warning displayed in the console. 

Version 2.0.0.3 
 
• Revised model generation so that overlapping particles are discarded to 

prevent density problems during analysis.  Processing is in model creation 
order. 

• When you append a CAD object to a scene you can split the object into 
parts (the same behavior as when you are initially loading a CAD model). 

• When creating interior particles you can now specify outside spacing. 

• Analysis data generation now works only with the active panel, not all panels. 

• Implemented Difference, Intersect, and Union Boolean operations.  Also 
implemented multiple object selection. 

• A few cosmetic changes.  

Version 2.0.0.2 
 

• Added the “Window” menu so you can reset the default window size easily. 

• Parts in an assembly are now colored using the Default Indexed Color tables 
instead of the current point color.  Also changed the selected object color so 
it doesn’t conflict with the default part colors. 

• “New Assembly” was adding an extraneous item to the Tree View.  Solved. 

• The scene sometimes wasn’t entirely redrawn when you edited the 
geometry.  Solved. 

• The normal vector for the cutting object could be too short and therefore not 

visible when cutting oblong objects in the long direction.  Solved. 

Version 2.0.0.1 

• The “Home” button wasn’t working.  Solved. 

• Added a "Busy Cursor” between loading a file and displaying it so there is 

additional feedback when you load a large file. 

• Added "propval" feature to export templates.  This allows some data fields to 

be set to internal property values so that we don’t need to prompt for them. 

• Updated the FlowHeatContainer and HeatContainer export templates. 

• All HTML help files have been replaced with PDF files that are located in the 

installation “Docs” folder.  Additionally, the help file is now actually a User 

Guide containing with more graphics and examples than before.  To view 

the help file you must separately install a PDF Reader such as Adobe 

Acrobat Reader. 

• Point Picking could pick values that had been hidden by a “cut” operation.  

Seems to be solved by using a different kind of picker widget. 



  



Known Issues and Limitations 

• Subtract and Intersect do not work on STL objects unless you use the 

“extended reader”.  That was the reason for adding the extended reader. 

• The IME (Input Method Editor) does not work in inline mode in the text editor. 

• The internal File Browser does not support Drag and Drop.  This was 

implemented, but the mouse behavior was too funky in some cases, so this 

feature is disabled for now. 

• Startup can be slow if the internal File Browser is enabled and you have a 

slow, mapped network connection.  Observed on a busy WiFi network; may 

not be as obvious on a hardwired connection. 


